127.0.0.1:8384 gui not accessible after shutdown/start syncthing

(giorgos) #1

Hi!

Through gui I shutted down the service in device Desktop(I wanted to be safe restoring a backup .config/syncthing/* to device Laptop,alltogether syncing with device home-server). Started again syncthing service with

sudo systemctl start syncthing@myusername.service

then gui was not accesible anymore from 127.0.0.1:8384. Edited ~/.config/syncthing/config.xml replacing 127.0.0.1:8384 with my the actual IP, after that gui was accesible with actualip:8384 but it’s something I don’t support, would like to get it back to 127.0.0.1:8384

Edited again ~/.config/syncthing/config.xml and added 127.0.0.1:8384

In Setings>GUI there is a notification

The GUI address is overridden by startup options. Changes here will not take effect while the override is in place.

127.0.0.1:8384

0 Likes

(Audrius Butkevicius) #2

Something is overriding it on the command line or environment var.

0 Likes

(giorgos) #3

I don’t know what to look for :slight_smile:

0 Likes

(giorgos) #4

Interesting is I put in ~/.config/syncthing a 2 days old backup and still the same problem (when the backup was taken there was no problem). I have to look somewhere else but syncthing. Thanx for watching anyway :slight_smile:

0 Likes

(eloim) #5

Dumb question but are you sure you look in the home folder of the username starting the service? Maybe you’re not modifying the right config file. I made that mistake after creating a specific user for the service. If you have a start up option gui-address =<address>, I think it would override your xml config file.

0 Likes

(giorgos) #6

Well no, there is only one user for the syncthing service. BUT! this post initiate me to open and read the /etc/systemd/system/multi-user.target.wants/syncthing@username.service file, and what I found was that the LAN ip of the machine was declared in ExecStart instead of 127.0.0.1

[Unit]
Description=Syncthing - Open Source Continuous File Synchronization for %I
Documentation=man:syncthing(1)
After=network.target

[Service]
User=%i
ExecStart=/usr/bin/syncthing -no-browser -gui-address="192.168.AA.BB:8384" -no-restart -logflags=0
Restart=on-failure
SuccessExitStatus=3 4
RestartForceExitStatus=3 4

[Install]
WantedBy=multi-user.target

I really don’t know how this happened, I have never touched this file before.

What and how I solved was to stop the service,

sudo systemctl stop syncthing@username.service

make a copy of the symlink and a copy of the service

sudo cp /lib/systemd/system/syncthing@.service /lib/systemd/system/syncthing@.service.bak

sudo cp /etc/systemd/system/multi-user.target.wants/syncthing@username.service /etc/systemd/system/multi-user.target.wants/syncthing@blades.service.bak

and edited the /etc/systemd/system/multi-user.target.wants/syncthing@username.service replacing 192.168.AA.BB:8384 with 127.0.0.1:8384

then enabled the service again for the symlink to be recreated from the edited file

sudo systemctl enable syncthing@username.service

and started the service again.

Thank you all.

0 Likes

(system) closed #7

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

0 Likes