0.14.52 file deletion issues

Summary of the machines invoved is as simple as they come: Windows box set up as read-only with watcher enabled, synced to Synology DS214+ set up as read/write with watcher disabled.

Upgraded to 0.14.52 today and started having file deletion issues. Unlike the usual problem Syncthing has of deleting empty folders inside “special” Synology folders (/photo, etc) which I handle manually, this issue affects files in directories that previously had no problems deleting anything. This is what shows up in the logs:

All the support topics mentioning this “file modified but not yet rescanned” problem do not appear to be relevant since no case-only renames were involved. Here is what I have tried:

  • Deleting the affected file on the Synology side: No effect. Scanner picks up the difference upon manual re-scan, syncs the file but file status remains “modified but not yet rescanned”.

  • Renaming the affected file on the Windows side: No effect. The renamed file is copied over, but the original file is not deleted and remains “modified but not yet rescanned”.

  • Renaming the affected file on the Windows side, waiting for it to sync, and then deleting both it and the original on the Synology side: Seems effective based on a sample size of 1 but also inefficient. It takes about 5 minutes to complete a manual re-scan and 2 minutes to find a specific file on the Synology box, multiply by 79 files affected.

  • Wholesale deletion of the entire folder containing the affected files on the Synology side: Effective but also very time consuming and wasteful. There were only 153 files to re-sync in this test case. There are 150,000+ potentially involved total.

So now I am left with the option of either spending 7 hours re-naming and deleting files, pinning the DS214+'s poor little ArmadaXP to 99% or nuking the whole folder and waiting for 2 days to rebuild everything. Surely there must be something else I can try.

Have you tried renaming the files to match the file case as it’s shown in the error message?

The cases already matched, as I mentioned before no case-only renames were involved.


I want to confirm that I have the same problems since the update without changing anything else. Interestingly, I also have a Synology NAS as a syncthing node.

I read in the forum yesterday and found the “case-only rename problem” discussions. But for me it is different: a normal synced file made problems (as mentioned above) after deletion (without any rename).

I can give more informations (logs, senarios, detailed tests) in the evening, if helpfull.

I believe you have not changed the case, I am asking if the case in the error message matches the case in the filesystem.

Yes, the cases match. I can give examples this evening if necessary.

Yeah. Please provide the actual error message with the file name visible and the file visible in some file explorer/ls output.

I made many tests today and here are the results:

I have three nodes A(Win10)/B(Synology DS415+)/C(Manjaro Linux) and one shared folder (with all syncthing configured as a triangle), everything is “Up to date”.

I add a file “P.JPG” from A into the folder and a file “M.JPG” from C and wait for the sync to complete. Every three nodes show “Up to date”.

When I now delete both files on A or C (regardless) “M.JPG” will be deleted, “P.JPG” will not (on node B).

Here are some pictures: both files on Synology File Manager Screenshot%20FileStation

both files with ssh/ls:


syncthing on B after deleting both files

the error message Screenshot%20Syncthing%20Error%201

and the corresponding loglines:


On device B, do you have the ignore permissions option enabled? If yes, I might have found a bug that could cause this.

Hm yes, I enabled this on my nodes to find a solution/workaround for this strange “non-delete-behaviour-on-B-when-file-from-A” and didn’t switch back.

On all devices? For “my bug to fit” you’d need to have it disabled on the device where the file is created, and enabled where the problem occurs.

the configuration is:

A: Ignore permissions : NO

B: Ignore permissions : YES

C: Ignore permissions : YES

Does the problem disappear when you set B to NO?

I changed B to NO and the test (JPG in folder, wait for sync, delete JPG) ended without an error.

Whooho. Thanks.

Can you file an issue on github describing what you did and what happened please - more or less your post here from an hour ago. The third device isn’t actually relevant, so you could leave that out.

OK, I will try…

I have also changed ignore permissions to NO on my Synology box. And after a lengthy re-scan, I am not sure if that fixed it because the problem that had been fixed by ignoring permissions has now been un-fixed:

Unfortunately there is no workaround in Syncthing if the required permission is missing, you’ll have to wait for 0.14.53 or make change user/owner/perms for affected files.

So now that 0.14.53 (and even 54) have been released, I was able to update my Windows machine, but the update does not appear for my Synology box. I haven’t really actively anticipated an update before, so I’m wondering if there supposed to be some lag time?

We are not the ones managing synology releases.