Win 10 laptop not connecting to home network

I set up a home network a few months ago installing syncthing on: One Manjaro Linux laptop Two Win10 laptops Two Android phones

But now one on of the Win10 laptops is not connecting to the network. All other nodes still detect each other. The problem started when config.xml was corrupted and all the data was replaced with null values. This problem has occasionally be reported in the past and I deleted the config.xml file and let Syncthing regenerate it.

I tried updating Win10 on the failed node, reinstalled SyncTrayzor/Syncthing, disconnected and reconnected the other nodes, and opened syncthing in the browser rather than Synctrayzor. I am not sure if everything uninstalled because when I reinstalled, the computer still remembered which devices to connect to and which folders to share, but could still not connect.

When I try to reconnect the failed node, the other computers on the system detect the nearby device id for the failed node, but the failed node cannot detect device ids for the working nodes. When I start the connection from the good nodes, I do not get a message to accept the connection request on the failed node. If I start the connection by typing in the device id on the failed node, the good node does not get a request to accept the connection.

The computers appear in each others Remote Devices list, but always show as Disconnected. When looking at the Remote Device Address (for the failed node) on the working node, I get “tcp:// The requested address is not valid in its context”.

How can I fix this?

It’s difficult to say what is going on specifically, but I’d suggest to try to reset the settings once again. Please check to see where exactly configuration files are located, and then make sure to delete all of them before trying to set Syncthing up again.

Also, files becoming corrupted may signal hardware issues, so please verify that all components are in good condition, and especially the hard drive.

You should also check whether Windows Firewall is not blocking the access. You can verify this easily simply by disabling it temporarily.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.