What are the correct network settings for an android+windows / home server setup?

As my nodes experience some problems keeping connections up, I would like to ask for the proper network settings. My setup so far is:

1 Server node:

RPi 4 / 4GB (Performance ~44MB/s) NAT-Router FRITZ!Box 7360, 1 Port forwarded TCP/2XXXX to Pi, DynDNS (server always reachable per SSH, 2XXXX always open from outside)

2 Client nodes running Windows 10 64-bit 1 Client node running Android 9

Client nodes behind NAT-Router FRITZ!Box 7240 at different location, UPnP activated, DynDNS (another pi behind this router is always reachable), or over mobile internet. Connection issues are affecting all 3 clients but syncing of ~4GB was successful - when connection was up.

On both routers IPv6 dual stack activated, both DynDNS IPv6 dual stack

On the server node following settings were applied:

Listening address: tcp://:2XXXX NAT-Traversal: no Global Announce enable: no Local Announce enable: no

Following settings were applied to clients:

NAT-Traversal: yes Global Announce enabled: yes Local Announce ensbled: no

External device (server node) address: tcp://(DynDNS-URL of server):2XXXX

Are this the intended settings for the described setup? Are there other settings that are relevant for connectivity?

Greetings

Why didn’t you just leave the settings as per defaults?

Well, I wanted to use a non-standard port at the server node for security reasons and guessed that no global discovery is necessary in that case. Further my nodes having problems to maintain connections and I tried every combination of the mentioned settings. Before you ask for logs etc, I just wanted to ask for the proper settings for using port forwarding and UPnP in order to rule out any coarse mistakes before going into detail, as specially NAT traversal is a complex area. BTW why a counter question, is anything unclear about my question? :slight_smile:

Greetings

Upnp only makes sense with global discovery enabled, as there is no way for the other side to verify the port.

If the port is properly forwarded (you can check that using netcat), then it should work when specifying a direct address.

Your description is quite convoluted, so I am not sure whats going on, nor have you explained that the issue is, are they generally unable to connect, or the connections are dropping, if they are dropping how are the connecting etc.

1 Like

I apologize for my complicated asking style and would like to thank you very much as confirming my assumptions is helping a lot.

Also the “tables” I put into the form were a little bit disarranged :slight_smile:

I have the situation that the clients and the server will not hold the connection. It is established when the server or the clients are restarted but will go inactive after a while when the devices are unattended. They will reconnect spontanously from time to time several hours apart. I have observed that when establishing a SSH Tunnel with putty and opening the web GUI of the server node the connection is reestablished a moment after. For now I am investigating further and will open a new thread when I was able to encircle the problem further and have collected sufficient information like logs etc.

Greetings

Opening the web ui has no impact on attempts to connect. Are you sure your device isn’t just sleeping or something, or your DynDNS stuff stops working.

Or using systemd user service or encrypted home dir so that it’s not actually running when you’re not logged in…

“Or using systemd user service” could be as easy as that… I was expecting that a user service is just a service running under a user, not that it will actually only run when this user is logged in… Then: I let an instance running from command line in a screen. Never saw it offline since yesterday. Guess for Linux there is a rule: a true master is an eternal student. Just improving my understanding of systemd now :slight_smile:

Thnx and Greetings