Very slow android transfer speeds on local network

Hello, I’m not sure if this is expected behaviour or not but I feel like this has happened since an update.

Running 1 windows 10, 1 macOS Catalina, and 1 macos Big Sur (M1 Silicon) all of these are at 1.16.1. My Android is at 1.16.0 (waiting for the latest and greatest to be built on F-Droid)

All 3 laptops are easily getting in the MiB range, whereas Android is topping out at 100KiB, usually in the 0-25KiB. Folder changes are 3406 files well under 200 Mb worth so I don’t know if this classifies as “lots of files” which I know can slow things down but I haven’t experienced anything this slow previously.

The logs on the Android device (side question: Is there any means of capturing/outputing/exporting this to be able to do better analysis on it) look quite different than the other in that it’s all rest calls, and it appears that it’s calling/checking every second the status of all folders, which are all in sync except for the one that’s slow.

I’ve tried using compression as my CPU is always at 0%, ram 84.7MiB… download here is more accurate and polls more often and I’m seeing 919B/sec up to 56 KiB/s, but usually under 10KiB/s.

I also was seeing a lot of ‘TLS’ in my logs, but they seem to have disappeared, or the high number of checkboxes i selected in debug are watering them down significantly. And a weird device with ID of bunch of 7s pops up once in awhile 7777777-777777N-7777777-777777N-…Q4.

In the non-web GUI windows menu popout, I do have 0/0 in red for Announce Server, but I’ve hard coded the static IPs assigned by DHCP and turned off Global, relay, Nat, Local announcing as everyone knows where everyone is.

On a side note, or maybe totally related, I’ve seen the Android’s address as being the proper IP but not the expected 22000 as all the other devices have. Currently, it is showing up as 22000 on the one device I have available to sync with it. Possibly useful as well, when it wasn’t 22000, it was on the Macs, the Win10 laptop was showing it as 22000. Seemed weird that all 3 laptops were showing up as 22000 on all other laptops, but the android device had 3 different ports across the 3 laptops, with just the windows being 22000.

Thanks in advance for your time and effort in supporting me in troubleshooting this.

  1. There is a new version of syncthing (1.17.0). Might solve your problem once it is being built for F-Droid.

  2. Have you checked this forum post? Please help: How can I get speed higher than 2 MB/s There, a lot of factors are mentioned that might have an influence on slow transfer-speeds.

  3. Was your setup working properly once before? Since when has there been problems?

Does it work better if you turn on Global, NAT, Local announcing?

Unfortunately i am not qualified enough to know about why your device would show up as 3 different ports. I could imagine, since you hardcoded ip-adresses, you also might need to hardcode to listen on your android-devices ports? (See Firewall Setup — Syncthing v1 documentation for how to forward ports. If you could teach me port forwarding for Syncthing, in case you succeed, i would be delighted, because i tried it and failed xD)

  • Do you get a connection with TCP, Quick or via Relay?
  • Also, some specifics about your used hardware (especially the android-device) would be nice to have for a more in depths analysis to exclude hardware bottlenecks, like cpu/ram/wifi/networkcard limitations.

Based on post-post performance, it was definitely tied to the large number of small files, which really blows my mind but then again, my skillset is not in that area. I noticed the same slow behavior on the macs upon syncing (for what it’s worth, it’s the Joplin sync, which can easily contain a ton of little resource files for each note and changing the structure in syncthing is not a matter of renaming the folders, but a complete refresh).

As soon as it was back to large files, flies like the dickens. No global, no relay, no nat, not even local announce… the hard coded IPs work well.

No need for firewall on my end as everything is local. I do want to get into external access, but lots of work to be done before that will get to the top of my to do list.

So let’s talk about your firewall/NAT/port forwarding issue. Not my wheelhouse but I’ve fudged my way through it enough times that I can probably help.

  1. What is your router?
  2. Does your router have UPnP and if so, have you enabled it? I personally think it’s a security risk, but it’s a great way to get the settings set properly and once it’s working, you can copy them, shut UPnP off, then enter them in manually.
  3. What kind of behavior are you seeing?
  4. Any other info you have that think could be helpful to cut down on the back and forths.


Great! :slight_smile: Good to know that you seem to have found a likely culprit for your problem!

And thanks for your offer! I opened this thread: How to configure Port forwards. Would be more orderly to discuss two separate issues in two distinct threads i think.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.