v12 does not discover discover computer behind a firewall

I have three computers at home and one at work. I tried Bitsync for about a year but it could never discover the computer at work. I switched to Syncthing which did. However since V0.12 was introduced my home computers no longer discover the work computer. All the computers show “Disconnected”. What can I do to make Syncthing work again?

v0.12 changed the port on which discovery is performed, so recheck your firewall settings.

1 Like

Thanks - I will look at that when I get to work on Monday.

Also, all nodes need to be running v0.12. You wording suggests that maybe you haven’t done that yet.

1 Like

Thanks for the most excellent suggestion. I have loaded V0.12 on all my nodes (computers) but it has made no difference. The computers do no longer see through the firewall. I have been hoping with each subsequent update the latest being v0.12.6 the problem would correct itself but alas no such fortune! One of my computers is a portable so I have resorted to sycning at home and take the portable to work where it syncs the work computer. Not a good long term solution

If your firewall is blocking traffic, no update of ours will resolve it. Ensure that the required ports are open and you’ll be back in the game, just like in v0.11.


Thanks for the information - it will take me a bit of time to digest what you have said, but I will perservere.

It does not look to me as if the firewall is the problem. Syncthing is authorised to go through the firewall at all levels; domain, private and public. It is also not subject to group control. On the home computer it maps the uPnP. The syncthing log reads “New UPnP port mapping: external port 26858 to local port 22000” and “API listening on”. It is also interesting to not that the two home computers on the same network like via a relay?.

Sounds like

Apart from that being fixed a while back, and that we always always prefer a direct connection of any kind over relay.

I have checked the firewall at work - it does not seem to stop syncting. It does not however activate uPnP. The log says “No UPnP device detected” Any suggestion which will cause the computers to discover each over?

You need either side to be available on the internet, or port forwarded or upnp to work.

Worst case it should fall back to a relay, which I am nt sure why it doesn’t. You should run with STTRACE=relay envvar and see whats happening.

Not sure how i run “STTRACE = relay envvar”?

I tried putting into the DOS COMMAND line - it did not run I tried as http://Sttrace = relay envvar I put it into the sync bat file - it did not harm not sure it did anything but the log file may now have more information. One line reads:

“[EU6AG] 10:25:46 INFO: Couldn’t fetch release information: Get https://api.github.com/repos/syncthing/syncthing/releases?per_page=30: dial tcp connectex: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond.”


“[EU6AG] 10:55:46 INFO: Usage report: Post https://data.syncthing.net/newdata: dial tcp connectex: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond.”

Run set STTRACE=relay on its own line before starting Syncthing from the DOS command line.

It seems (judging from thr log lines you pasted) that you are behind an unreasonably strict firewall, which potentially means there is very little we can do.

That is a pity. I work at a university and the IT administrator would not make a hole in the firewall for BitSync because of concerns that students would find a way to download videos. I could not get the IT administrator to distinguish between BitTorrent and BitSync. I was delighted when I loaded Syncthing because it immediately worked. It stopped working with V0.12.xx. It is not clear to me that the problem is in fact the firewall because syncthing has not been blocked at all nor is it governed by the group policy which was the case with BitSync. I have temporarily moved some of the files to OneDrive till I sought out the problem with Syncthing. I stopped using OneDrive when it took several weeks to sync files. I do not have that problem with Syncthing which syncs folders very quickly. I also find it difficult to split my data - some on syncthing and some on OneDrive.

If your firewall is blocking outbound connections left, right, and center (which is what it looks like it’s doing from the logs) then there’s very little hope of anything working.

Given that HTTP requests to GitHub are being blocked, I’m surprised you can use the internet at all.

Exactly, either your local machine firewall is very restrictive on syncthing (so that it can’t even access github page to check for updates) or your corporate firewall is blocking pretty much all traffic.

I suggest you refer to the firewall section of the docs and recheck your firewall settings, as some ports have changed between 0.11 and 0.12

Can i put the sttrace in the bat file? ie

“SET STTRACE = Relay Start “syncthing” syncthing.exe -no-console -no-browser”


start "syncthing" syncthing.exe -no-console -no-browser"