Utterly at a loss to interpret syncing error

I see this (on Windows, though I sync to Linux and Android):

This is so opaque I’ve filed a bug about it. But I was told to ask what to actually do about it, at my end, here. So: any ideas, please? I was pointed also to something about problems owing to the case of characters - but I’m unsure that is the case here. How do I troubleshoot, please? (Stallman: freedom is worth the inconvenience. Me: you never told me just how much inconvenience . .)

Did you actually check the logs like I suggested?

No. I apologise. Mitigation: I was too irritated. (This is the third time, over some three years, that I have tried to get Syncthing working. And, frankly, look at the window I posted. That window is a disaster, it seems to me. So, given all this - and, admittedly, the amount of bug reports I file for Linux program - I’m pretty frustrated.)

Here (pastebin; 6-month expiry) is the syncthing log from the Windows computer.

EDIT: according to the log, the problem - well, the problem besetting one file (I deleted the other file from all devices) is:

item "PCs\\CW\\general\\Liz pword (case sensitive):"): filename is invalid

The file name contains a colon. That’s not a possible thing on Windows.

The dialog you pasted is a list of items to sync, with activity (if there is any, which there isn’t in your screenshot). There is also a separate “failed items” in the GUI where you would get the same error as you see in the logs.

Thanks. However, I do not understand you. Is there somewhere that I can look for more information, and where you would like me to look, or not?

Anyhow:

  • I had removed the colon from that filename already and that seemed to fix that problem;
  • a problem with another file somehow got cleared up;
  • Then I had a problem with another file, perhaps because its full name (including path) was too long for one of the computers. (Except, oh, mere I may have misintepreted ‘out of sync’ as ‘unsyncable’ . .) I delete the file (actualy, folder) in question.

It seems to me that syncthing should do more to anticipate these problems and more to help the user remedy them.

Synthing does gives one some error messages, such as this one

But it seems to me that, if one misses that notice, it is hard to find the information again. At the least: I’m having a hard time understanding how things are supposed to work. Also, though: ‘dropping index entry’? Does this mean syncthing has solved the problem?

Yes, the “failed items” in the GUI, below the “out of sync” ones you showed. I don’t have a good screenshot at hand, but stole one from another topic:

I don’t need to see it because we know what it says, I’m just pointing out that that is where you see the errors.