Upload rate limiting not working in v0.10.27

Has anyone else noticed that with the upgrade to v0.10.27 the upload rate limit will no longer limit? It worked fine before I upgraded. I have a 5 meg connection at home and when I sync a folder to my friends I have limit set to 300 KiB/s however it will max out my upload on my cable modem.

What version were you running previously? v0.10.26 introduced a fix for not limiting bandwidth within LAN:

Can you run with STTRACE=net and then look for the line which says cipher suite. You can also provide one line above that one which shows the connection IPs.

I assume you might have some VPN setup between you and your friend, which might be causing this? You can disable the feature by editing config.xml.

I believe I was using 0.10.26… I haven’t had it installed for more then 2 weeks yet… and it was limiting just fine then… I found the line your referring too in the config.xml file I did notice before they were global as I was syncing between 2 machines on my lan but the one going to the WAN was the one I was concerned about and speed wasn’t an issue yet. That right now is set to false so is it still a global setting I figured it wasn’t anymore and it should be able to tell between WAN and LAN.

No there is no VPN… we are just using the internet. I have freebsd router and I don’t know what he has both are set to dynamic on the discovery as well.

Sorry, so are you saying a WAN device is identified as LAN? What does the cipher suite line say? Can you check what IP it shows when you connect to your friend?

Yes it would appear that it is identified as a LAN device… it is clearly on the net… my box is and his is 173.80.x.x (ip address changed to protect the Innocent) so it is defiantly not on my network.

as far as running with STTRACE=net can you clarify how you want me to run that… put it in the config.xml? is that a switch on the command line /sttrace???

I cannot find anything that says cipher suite


Set the environment variable. That varies by OS. Do you have Golang runtime installed bt any chance?

I assume you tried disabling it in the config and it works fine?

Yes I did set the limit lan to true and it did limit bandwith everywhere… I don’t have go installed but can if it would help… and I set the environment var and rebooting now… btw windows 7 64 bit is my OS with 16 gigs of ram.

OK the environment variable is set and it still does not limit bandwith to the internet.

and here is the cyper line

[L5FEM] 2015/03/19 00:11:35.935126 connections.go:127: DEBUG: cipher suite: C02F in lan: true

Can you also provide the connected to line which shows the IP as well as your IP and subnet masks of all ethernet adapters

I will try to make a small binary which just prints networks we find to help debug this.

Can you run the following Go script:

package main

import (

func main() {
        lans, err := osutil.GetLans()
        if err != nil {
                fmt.Printf("Failed to get LANs: %s\n", err.Error())
        for _, lan := range lans {

Or if you trust me, just run lans.exe (2.2 MB) and provide the output.

(the last one is my virtual box network)

not sure which connected line you mean I see several connections… like this one

2015/03/19 00:37:16.725254 connections.go:175: DEBUG: connect from 173.80.XXX.XXX:62793

[L5FEM] 2015/03/19 00:37:17.713310 connections.go:125: INFO: Established secure connection to NW355SL-XXXXXX-XXXXXX-XXXX… at

to the machine that I cannot limit the bandwith too…

Yeah seems to be the culprit. Given you are running windows, do you have IPv6 connectivity?

No I do not have ipv6

should I disable it on the adapter?

How many network adapters have you got?

just 1 adapter … need more characters here they are

Is that one physical network adapter, or is that the number of adapters in Network settings?

Regardless, I’ve submitted a fix which fixes this, hence should be fine in the next version.

yes I have 1 physical adapter

one TAP one teamviewer VPN one Virtual box and one work VPN…

ok I will just wait for the next version … I have it adjusted right now with traffic shaping in my router… it is set low so if anything else needs the bandwith it slows down… Thank you so much for the prompt attention Audrius