Upgrade from v0.10.29

Using SyncTrayzor on wife’s laptop (Windows 7). Looked at gui and offered v0.10.31 interim upgrade.

This crashed with request to raise an incident. Saved crash info.

Tried again - failed again.

Double-clicked syncthing.exe in SyncTrayzor program files folder.

gui said v0.10.29., as did log

11:06:17 INFO: syncthing v0.10.29 (go1.4.2 windows-amd64 default) unknow n-user@syncthing-builder 2015-03-22 14:09:14 UTC

After initial scans

11:06:39 INFO: Automatic upgrade: Get https://api.github.com/repos/synct hing/syncthing/releases?per_page=10: dial tcp: GetAddrInfoW: No such host is kno wn.

I suspect that upgrade from v0.10.29 to v0.10.31 is not catered for.

On my laptop I’m on v0.11.1 & Trayzor 1.0.16, but I did go through c0.10.30

How should I proceed? Do I install v0.10.31 manually?

Do I run it standalone or via Trayzor?

Do I need to uninstall Trayzor and then reinstall the latest version afterwards?

You can jump between upgrades freely, as all that does is replaces the binary underneath, so there is no need for “gradual” upgrades. Also. if it says it’s 0.10.31 in the web ui, then what’s the problem?

The error you are seeing is something todo with how your OS performs DNS resolution (it seems to be unable to resolve DNS for github).

oops, gui said v0.10.29

original post edited

Can you access https://api.github.com/ through the web browser? I think your problem is that you DNS server not resolving github, hence it’s potentially DNS settings/server to blame, nothing todo with syncthing.

Yes, I can access via webserver

On the same machine which showed the error? Then I suggest you try upgrading again, if that fails, just upgrade manually by downloading a new release. Not sure what the issue is, and why Windows refuses to resolve the hostname for us.

Yes, the same machine.

You’re right, it wasn’t syncthing but SyncTrayzor.

I must have missed a disconnection earlier.

I’ve now got syncthing up to v0.11.1 outside of Trayzor.

It looks like SyncTrayzor is at v1.0.11 according to CHANGELOG.txt, and this can’t cope with syncthing v0.11.

Perhaps @canton7 can advise, but I should be able to install v1.0.16 and all should be fine.

It seems that I was caught out by a mixture of automatic and suggested updates and ignoring notifications on my wife’s laptop.

Aha, so you’re the sole person on v1.0.11! I knew from the logs on the upgrade server that someone was still on 1.0.11, but no more detail than that.

Yep, Syncthing 0.11 compatibility was introduced with SyncTrayzor v1.0.12. Just download/run the latest installer - that’s fine. The newer SyncTrayzor versions (post-v1.0.14) are much better about getting you to upgrade: they show an alert above the taskbar, and it’s a single click of a button on that alert to upgrade.

SyncTrayzor v1.0.11 had a bit of an issue where it could incorrectly downgrade Syncthing after it had auto-upgraded: this behaviour was tweaked in 1.0.16. It sounds like this was causing your problem.

1 Like

Part of the problem was that I set “Hide icon and notifications” on wife’s laptop so she doesn’t get disturbed - after all, it’s supposed to be a background process.

But if you were to introduce remote notifications (I think it’s probably overkill), I might just use it.

I don’t honestly think that “remote notifications” will ever be a thing - I think you’re the only use-case for them! Unfortunately I can’t do completely silent updates either: I need that UAC prompt, although I’ve reduced the process to just clicking “Install” and accepting the UAC prompt.

To be fair, this thread was only opened because you tried to update Synthing without also updating SyncTrayzor. As long as you remember to update both together in future, you should be fine (indeed, SyncTrayzor installers always ship with the latest Syncthing, at the point that the installer was created).


Well, if I can’t get remote notification past you, how about write-only storage? http://www.supersimplestorageservice.com :smiling_imp: