Untrusted device doesn't finish syncing when file last modified by unknown or old device

This is a follow up to Bug: Receive encrypted when the last device that changed the file is not available · Issue #7825 · syncthing/syncthing · GitHub

Essentially I have a bunch of devices, some of which I have retired. All of these sync in a trusted fashion to each other but I recently tried out the untrusted node feature. It however never finishes syncing - it is stuck on 90% with ~388 files remaining. The error listed on the untrusted device is “syncing: pull: generic error”.

Except for a few files, almost all of the items out of sync seem to be last modified (as per syncthing GUI) by either “unknown” or an old device ID). Touching the files ($ touch) fixes the sync for that file, as does moving the file/folder affected out and in of the synced folder node. I don’t want to change the mod time for all these files to workaround this bug for obvious reasons.

I have attached a log as per above github issue with model logging enabled

Relevant devices

trusted-a (first device I attempted to sync to untrusted device) BWOKBR5-TRUSTED-A

trusted-b (current device - same issues with above device) PW4CYMW-TRUSTED-B




I am utterly clueless what’s going on here: The request comes in, gets logged with reasonable parameters. And then a while later again. No errors logged. There’s no error return that isn’t accompanied by logging, and there’s no error in the encryption wrapper between model.Request and sending the data. So no clue whatsoever where this generic error you are seeing on the encrypted devices is coming from.

Well I don’t think it’s just my configuration as I’m pretty sure the other person on github has the same problem. Is there any other debugging things I can do?

If not I will just make a script to set the mtime for all affected files to +1 sec to workaround this, but I imagine other people will pop in with the same issue.

I didn’t want to imply it’s something specific to your setup/config. That’s generally a possibility, however here there’s both many reports of very similar issues and the logging-error-mystery I described above applies to the source code, so that’s generally applicable (unless arch did apply very weird patches, and afaik they don’t patch at all unless absolutely necessary). I just wanted to express that I don’t understand at all what’s going on here :slight_smile:

However I missed one obvious question to be sure: Did you filter out any of the lines in the log?

And another debug facility that might contain clues is protocol.

No lines were filtered out.

I ended up fixing the documents sync manually as I wasn’t sure if you were coming back, but my other folder (dev) has the same issue. What’s weird was that turning on protocol debugging actually made 99% of the remaining files sync (lol). I still have 3 out of sync - two of the files are either unknown or from a old/retired device, and one is last modified from the device I’m syncing from (trusted-b)

I am having this same exact issue. Worked around it by updating the mtime, thanks for sharing…

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.