Unable to run syncthing on Ubuntu 15.04

I have syncthing running on Ubuntu 14.04 on my Desktop computer no problem, but when I tried to install and run it on my laptop with Ubuntu 15.04 I am unable to get syncthing to run. In the command line I get the following errors: FATAL: cannot open database: leveldb/table: corruption on table (pos=0): too small [file=001601.ldb] - Is another copy of syncthing running? INFO: Syncthing exited: exit status 1

This is a fresh install of syncthing on this system and as far as I can see from the process menu there isn’t another copy of syncthing already running.

I have tried using both the repository install, and the manual install using the executable, both with the same errors.

Any help would be appreciated.

Sounds like there is a corrupt database in place, so maybe not a clean install after all? rm -rf ~/.config/syncthing will make it one for sure.

Thank you for your fast reply.

Your solution worked a treat and the issue has been resolved.

I appreciate your help on this matter.

1 Like