Unable to delete Folder

All of the following is being done on the ST GUI.

I was trying to setup a sync between my Synology NAS and my Unraid NAS. I never did get the sync to work so I deleted ST from the Unraid NAS. On my Synology NAS, I deleted the Remote Device. I tried to delete the Folder. But, when I try to edit the folder to remove it, I get the big red warning box with :

" Connection Error. Syncthing seems to be experiencing a problem processing your request. Please refresh the page or restart Syncthing if the problem persists. "

It happens so quickly that there is no opportunity to get in to edit the Folder to remove it. ( I do not want to removed to actual folder on the Synology, just the reference to it on the ST GUI.)

I’m not at all conversant in using the CLI.

This looks like the same problem as reported in https://forum.syncthing.net/t/connection-error-in-browser-and-synctrayzor-when-deleting-a-folder/21193/2 (and some other topics before). Please try to follow the same instructions, although you will need to find where config.xml is located on your system first.


Thanks tomasz86. I stumbled around a bit with ssh but didn’t get anywhere.

I took another look at problem folder in ST and saw on the error line that it was a permission issue. This is how I solved the problem :

  • Go into the Synology Shared Folders area,
  • Select the share that had the permission issue,
  • Change from Local users to System internal users,
  • Give sc-syncthing Read/Write privileges,
  • Go back to Syncthing, select the problem Folder, Edit…

…and presto, the error message disappeared and I was able to delete the Folder share in ST.

Can anyone explain how to reproduce this problem? It shouldn’t happen and should be fixed.

I’m not sure if this is the same, but one way to cause this issue (or the same behaviour at least) is to add a folder on Windows using double quotes, f.e. C:/"test".

This isn’t allowed and causes an error, but it’s added to the config nonetheless. Afterwards, when editing the folder in the GUI,

DEBUG: http: GET “/rest/db/ignores?folder=j2fxl-exthq”: status 500

prob causes the GUI to error out permanently (till a reload).

But, there may be different or other reasons as well. Not sure if the OP’s issue is this.

Got it, I can reproduce it.

More specific;

DEBUG: ignore.go:383 basic C:\Users\ericp"123" Open .stignore CreateFile \?\C:\Users\ericp"123".stignore: The filename, directory name, or volume label syntax is incorrect.

I think the way I created my problem was that in ST, I created a folder share that ST did not have permission to share. The share showed up in the GUI and that was the end of the ability to do anything with it until I later added the permission. It’s been a couple of weeks since I did this so the ordering is a bit fuzzy.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.