Umask does not work in Syncthing

I am on Tumbleweed and use latest version:

v1.23.7, Linux (64-bit Intel/AMD)

Maxim     8356  0.0  0.0 732572 17916 ?        Ssl  01:48   0:00 /usr/bin/syncthing serve --no-browser --no-restart --logflags=0
Maxim     8365 19.5  0.4 1077380 158688 ?      SNl  01:48   2:14 /usr/bin/syncthing serve --no-browser --no-restart --logflags=0

In systemd I used UMask to set it and it is applied, we can check it by:

grep '^Umask:' "/proc/8356/status"
Umask:  0077

grep '^Umask:' "/proc/8365/status"
Umask:  0077

But when Syncthing creates files it ignores umask:

-rw-r--r-- 1 Maxim Maxim         8 Aug 22 16:14 test.txt

Is “Ignore Permissions” enabled for the affected Syncthing folder?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.