Two syncthing hosts behind one firewall

I have syncthing installed on three systems:

  1. Macbook Pro
  2. Windows 7 desktop system
  3. Linux file server, running CentOS 6

The Mac travels with me.

My home network is behind two firewalls; the first is the Verizon router, which simply routes everything to the internal wireless router running a version of dd-wrt. The Windows & Linux systems are behind that router.

My Mac is able to connect to the Windows system without any problem, but rarely if ever connects to the Linux server.

I’m not sure if my problem is related to the fact that I have two systems running behind the firewalls, or if there is a problem on the Linux box. The Linux box and the Windows box don’t have any problems connecting together

I’m new here, and am not sure what to actually look for.

Thanks in advance


Using two devices behind the same firewall shouldn’t be a problem. Did you check if there is a problem, when your Macbook is inside the home network? Do you use UPnP or did you set up port forwarding manually? If UPnP, please check your UPnP table in your dd-wrt router; if manual, please post your port forwarding config you did for syncthing.

Macbook pro works fine inside the home network, to both systems. Outside, the Mac can only access the Windows box inside the network

Initially I tried using PNP for everything. After posting this, I decided to try a manual config for the Linux box.

I changed the port on the Linux box to 22001, and set up a port-forwarding rule on the router, to forward 22001, both tcp and udp, to the linux box. No change. I did restart syncthing after changing the config.

I verified that the device ID was correct on the Mac and the Linux box

Here are the portforwarding rules I got on the router:

This first line is forwarding to the Windows box, set up by uPNP in the router: logaccept tcp – anywhere tcp dpt:22000

This is what I set up manually to forward to the Linux box (known internally as mailer): logaccept tcp – anywhere mailer tcp dpt:22001 logaccept udp – anywhere mailer udp dpt:22001

I suggest you try setting up a manual port forwarded on the linux machine, and verify that the forwarding works using netcat or something.

I already have that. I have been running owncloud, which has been working fine for several years using a port forward to the same computer.

Is it possible that the udp forward is messing it up? I just turned it off, and at least over the mifi device I have here, my Mac was able to connect to both systems.

I’ll test it tomorrow when I get to work, where it has not been working

It appears that disabling the UDP port forward solved the problem. I am now connecting to both servers behind the firewall.

Does this make any sense to anybody?