Traversing Error Synology


I get the following error,

“error while traversing /volume1/xxxx/xxxxxxx/xx/xxxxxxxxxxxxx: permission denied”

I’ve tried changing permissions but can’t resolve this. Any help much appreciated


With which user are you running syncthing?

I’m changing the ‘system internal user’ '’s permissions. Installed it under an admin user

Make sure to enable the “Ignore Permissions” options under advanced options for each folder. Otherwise Syncthing might try to set the UNIX permissions and thereby erase all of Synology’s ACL-based permission assignments.

Other than that, you’ll probably have to check each individual path component along the way and see if it has correct ACLs assigned so that can access them.

‘Ignore permissions’ is on. Ive tried changing the permissions for the folder in question too, still no joy.

I can also observe this effect on all of my Synology servers. On each there are two or three folders that it concerns. However, everything works normally, except for the notification of elements. Example:



So far it was not possible for me to fix that, not even with changes to permissions or something like that.


Unfortunately this seems to be an area where Synology is not handling permissions error-free, and it needs to be reset on the Synology Shared Folder to make it work correctly.

Here’s what works for me:

  • Pause the folder in Syncthing;
  • SSH into the Synology and raise yourself to root with sudo i
  • Remove the existing permissions on the shared folder - this will take a while to complete:
chmod -R a+rwX /volume1/Shared\ Folder
  • In Synology DSM Control Panel, assign the correct read/write permissions to the shared folder;
  • In Synology File Station, view the Properties > Permissions for the shared folder and delete any entries which you did not explicitly set in the Control Panel;
  • Ensure that the top-level permissions are correctly inherited to the subfolders and files. This will take quite a long time to complete, so we’ll set the command to not rely on the SSH connection being active (this is what the ‘&’ does at the end of the command):
find /volume1/Shared\ Folder -mindepth 1 ! -path '*/@eaDir*' ! -path '*/#recycle*' ! -path '*/#snapshot*' -execdir synoacltool -enforce-inherit {} \; &
  • Keep an eye on the find command running in Synology Resource Monitor (under SSH);
  • Once it has completed, unpause the folder in Syncthing.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.