totally annoyed: False out-of-sync and sync-conflicts

background: 3 devices worked for a year or more. 1 ARM synlogy linux, 1 amd64 debian, 1 amd64 xubuntu with some sync folders on NTFS external disk. i borked my xubuntu and had to reinstall. my NTFS disk was intact.

after reinsalling synthing 1.1.4, i continuously had sync-conflicts on large 4GB files. i tried syncthing -reset-database which i though was working but in time proved wrong.

i took the NTFS disk and connected to a known good copy (debain) and rsync’ed both ways, deleted sync-conflicts, then remounted NTFS to xubuntu and reset-database again:

#debian machine
rsync -avh --exclude=".*" /media/disk2/SYNC/QuadCopter/ /media/user/WD2TB/Computer/SYNC/Quadcopter/
rsync -avh --exclude=".*" /media/disk2/SYNC/YT-Archive/ /media/user/WD2TB/Computer/SYNC/YT-Archive/
rsync -avh --exclude=".*" /media/user/WD2TB/Computer/SYNC/Quadcopter/ /media/disk2/SYNC/QuadCopter/
rsync -avh --exclude=".*" /media/user/WD2TB/Computer/SYNC/YT-Archive/ /media/disk2/SYNC/YT-Archive/
find /media/user/WD2TB/Computer/SYNC -name "*sync-conflict*" -delete
find /media/disk2/SYNC -name "*sync-conflict*" -delete

#xubuntu machine / remounted NTFS here
syncthing -reset-database

waited for 1st fold scan to complete then found this in the GUI yet again: “Out of Sync” … “34 items, ~45 GiB”

it make no sense. this is with the ARM synology disconnected and the two remaining machines that should be exact duplicate copies connected.

v1.1.4 on all ; already “ignoring permissions” on all

du -hs /media/disk2/SYNC/QuadCopter/
314G	/media/disk2/SYNC/QuadCopter/

du -hs /media/disk2/SYNC/YT-Archive/
581G	/media/disk2/SYNC/YT-Archive/

Screenshots would be helpful.

Even if files are the same, there is still a process that needs to merge version vectors, until that is done, they are out of sync, even if getting in sync means just incrementing an integer in the metadata, so just give it time.

1 Like

will do, i’ll give it a few days and return here.

If it does not get better, post screenshots from both sides, yet given it’s a fair amount of data, and some devices are not the most powerful ones, it might take some time.

1 Like

just an update, went this whole time with problems daily until i removed the sync-folders from my ARM device.

had to manually rsync my 2 remaining devices, -reset-database, then was all good.

sucks because the ARM device is my “real” backup – but appraently can’t handle the large 300gb/500gb folders.

1.1.4 until 1.2 release date. both had the issue. ARM device is successful on 2 smaller folders (less work to do i assume).