This is how I set up file ignoring when setting up a new node. Is it the recommended way to do things?

Background: I have a folder with many syncthing ignores. One is a .stignore-global which I use for almost every partnership. It excludes OS-generated files like “Thumbs.db”. Then there are .stignore-[name] for different nodes depending on what they need ignored.

I use files instead of putting everything in the .stignore to make it easier to keep track of what’s being ignored from my work pc instead of having to go to each node and peek at the .stignore.

When I set up a new node

  1. first I share the folder to the syncthing on the device in question, from another device running syncthing
  2. On the target device I create the folder that I want to be the synced folder in a file manager.
  3. I copy into this folder .stignore-global and any other .stignores needed.
  4. I accept the partnership in Syncthing and fill in the folder options. I choose the directory I just created.
  5. In the ignoring section, I #include the ignores in question.
  6. I confirm creating the partnership.
  7. Syncthing now pulls everything.

I have, in the past, attempted to set up a folder telling syncthing to #include ignore files that weren’t placed there locally but were synced globally, in the hopes that syncthing would download this file first, then follow its instructions to ignore subsequent files, but I think syncthing showed an error because the #included files did not exist yet. Hence this is why I do things way I do currently.

Is this the recommended way to do things?

Yes, the file needs to be there to be included. There is no one recommended way for working around that, but what you came up with seems to make sense.

1 Like

Thank you for the clarification