SyncThing (Win10) cannot auto login -- how to solve?

Dear all,

At the very beginning after installed Syncthing on Win10, Syncthing can automatically logged in after run, but I am not sure starting from when, it need me to manually click on the “Sign in” button to login – pls. see attached screen capture:

So my question is, how to make it automatically login? Are there somewhere to set it and make it happens?

Thanks for any kinds of help!

You can just disable the authentication in the settings if not needed. Otherwise you should see how your browser or possibly a password manager can fill in the details automatically.

It is also possible to embed the password in the URL itself (e.g. https://<user>:<password>@localhost:8384). I find this useful when I want to have Syncthing protected from remote access but also be able to access it easily locally.

thanks acolomb for your comments!

but… I am not sure where to disable, can you show me which menu in the settings?

On the top right hand corner, click “Actions” → “Settings”, then:

→ what next?

or is it in “Advanced Settings”?

Thanks for any kinds of help!

Thanks tomasz86!

will try it out!

It’s under the GUI tab, user name and password. Sorry I can’t give s screenshot right now.

Thanks tomasz86!

The password embedded URL " https://<user>:<password>@localhost:8384" does work!


The problem is that I auto-run Syncthing by putting the shortcut of “Syncthing.exe” into the user startup folder: C:\Users<userName>\AppData\Roaming\Microsoft\Windows\Start Menu\Programs\Startup

So, is it possible to embed the password thru something like:

syncthing.exe --user:<username> --pwd:<password>


Better split up starting and opening the browser then. Add --no-browser to the command line in your autostart shortcut. Then add another shortcut for the URL, including the user and password.

Dear acolomb,

will try it out!


No use!

still need to click to start: Syncthing_auto-start problem

That’s unfortunate behavior of your browser. You could try to make it a “pinned tab”, so it opens every time. I don’t know if that will work without additional authentication, but worth a try.

Is this Firefox? If yes, I think there should be a preference in about:config to disable the confirmation pop-up. Chromium browsers seem to just log in without any questions.

not sure which item to disable in “about:config” (have tried to search “popup” or “confirmation”)

do you have any ideas?


Please check This is a hidden preference that needs to be added to about:config manually. Also, according to the description, there are some security-related implications of disabling the confirmation dialog entirely, although I’m not sure how relevant it really is, seeing that other browsers don’t use such methods to block automated logins.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.