SYNCTHING through Proxy/FIREWALL will not connect

Hi !

I’ve a little problem with Syncthing. Actually, my Syncthing in my local network, work perfectly with a computer under linux and 2 under windows 10 (SyncTrayzor). With my phone in local and 4G, everything it’s ok. But with my SyncTrayzor at work, no way.

I don’t have acces to the firewall of Network or the list of port blocked. The HTTP Proxy is add in environnement variable. SyncTrayzor gets the relay and the address contain my ip/port via TCP. But the 2 computers are with “last seen never”.

Syncthing version 0.14.5 (linux and windows)

What setting did i forget ? Thanks for your help !

Did you read the docs regarding proxies? It needs to be all_proxy, not http_proxy.

Additionally, if it is a corporate proxy, it could also block connection to those ports.

all_proxy don’t work. Synctrayzor unable to go out to catch the relay with this option. http_proxy gets me out to retrieve the relays of Syncthing.

Be that as it may, Syncthing can’t connect through an HTTP proxy. A SOCKS5 proxy set using all_proxy works though.

With all_proxy=socks5://XXX.XXX.XXX.XXX:8080 , no discovery service detected. No relay will appear in the address of the remote machine (only dynamic).

Is there other parameters for the environment variables ?

You can try specifying both, but that would require the ability to connect to the http proxy via the socks proxy. Also, if you get a relay via connection just with the http proxy, then whats the issue?

The problem is that the HTTP proxy, i join the relay but no connection is established between the 2 machines. With the parameter all_proxy SOCKS5, I can’t find the relays and the connection is not established.

If you can dial the http proxy via the socks proxy, my suggestion should work.

Yes, but how ? It’s possible to use multiples variable with a similar function ? I use http_proxy=XXX.XXX.XXX.XXX:8080 and all_proxy=socks5://XXX.XXX.XXX.XXX:8080 separate with an “space” and i change the order but no way. (SyncTrayzor)

A concatenation of both ?

I test with ALL_PROXY_NO_FALLBACK=1, but same result.

I assume putting both variables in the field should work. If not, you can start syncthing yourself, pre-setting the variables.

Separated be a space is correct: http_proxy=XXX.XXX.XXX.XXX:8080 all_proxy=socks5://XXX.XXX.XXX.XXX:8080.

It seems odd that XXX.XXX.XXX.XXX:8080 is both a HTTP proxy and a socks5 proxy…

It’s an HTTP proxy , not both. But previously , it’s said put the parameter on SOCKS proxy, not HTTP … XD. After 143259 tests, http_proxy give me a real IP address of my home device, at work, but no connexion etablished. Same result on the syncthing interface at home, I have the IP address of my work device, that’s all ! I don’t know bypass the filtering, because http_proxy don’t forward my connexion tcp for syncing the 2 devices.

You won’t be able to connect through an HTTP proxy. That discovery happens to work through it is an accident, more or less. You need an actual SOCKS proxy or the ability to connect outwards towards the internet without a proxy.

A SOCKS proxy is not a HTTP proxy. They are two different types of proxy. You can not use a HTTP proxy as a SOCKS proxy.

Syncthing requires a SOCKS proxy to connect to other devices, not a HTTP proxy. Syncthing uses HTTP for device discovery, but does not use HTTP for connections between devices. Therefore device discovery will work over a HTTP proxy (which is why Syncthing has found the IP address of the other device), but connections between devices will not work over a HTTP proxy - Syncthing needs a SOCKS proxy.

Telling Syncthing that your HTTP proxy is a SOCKS proxy, unsurprisingly, doesn’t work either. It’s still a HTTP proxy, whether you lie to Syncthing about it or not. You were told to use a SOCKS proxy, not to tell Syncthing that your HTTP proxy is a SOCKS proxy.

@calmh told you this right at the start:

He said that Syncthing cannot connect through a HTTP proxy. No wonder, then, that you can’t make Syncthing connect through a HTTP proxy (whether you pretend that it’s a SOCKS proxy or not)…

OK ! The explanation is more understandable. The connexion by Syncthing will not perform.

Thank you !

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.