Syncthing suddenly slowing down


(Clemens) #22

As I said before: I do not run with any limits.

I will do that, when I see the issue the next time.


(Jakob Borg) #23

Not the limiter then, I think. :slight_smile: I’d probably start with STTRACE=model. You can enable this in the GUI too, when things are slow, without requiring restart. It shows quite a lot about what it’s doing when syncing, but not necessarily exactly what’s taking time. You can redact file names reasonably (i.e., keeping unique things unique) before posting.


(Clemens) #24

Thanks, that is what I was asking for. I already looked into the different debug logging options, but they were not very clear to me.

I guess logs of the master and the slaves are relevant?


(Jakob Borg) #25

Probably, until we know on which side the issue is caused.


(Clemens) #26

I am probably not able to share something today since I had to restart them due to a bug in my script. I will try to find a test run tomorrow.


(Audrius Butkevicius) #27

I say I suspect limiter because we still wrap the connections, and I recall some infinity handling funkyness.


(system) #28

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.