Syncthing reindexing but why??

I’ve noticed that Syncthing will start a reindex on the node that I restart

Why is it doing that?

I’m seeing 100% CPU utilisation on my server which is slowing down a lot of other services

Is there any way to control this?

It’s not really reindexing (unless you’ve wiped out the database or something), but it does need to re-scan every folder for any possible changes that might have happened while Syncthing wasn’t running. The process can indeed take quite some time, especially when using low-end hardware and/or spinning drives.

There’s nothing you can do to work around this problem, unfortunately. The relevant issue is

As for the CPU usage, Syncthing runs with a lower priority by default, but if you want, you can try using your OS built-in tools to reduce the priority even lower. Just make sure to disable first if you do decide to do so. There’s also the GOMAXPROCS environment variable that you can tweak too.