Syncthing - Perpetual Fail?

I’m on Linux PopOS (which is Ubuntu 22.04) and syncing with a Google Pixel 7 Pro (GrapheneOS).

Installed Syncthing and ran it successfully and started syncing a 10 GB folder. Everything was smooth, even though the sync kept getting disconnected and reconnected automatically for some reason.

The Sync reached 95% and ever since then I’ve been banging my head against the wall for 2 days straight.

Because it just stopped at 95%. I didn’t do anything. In fact, I left the desktop and mobile on their own and was in a different room. And just peeked to check every once in a while.

Now it constantly switches between connected and disconnected. But when it stays connected for a few seconds the speeds are abysmal, like 2-3 Kb/s.

Which boggles my mind because initially I was getting 2-3 Mb/s and sometimes even 13 Mb/sec:


I’m also running Mullvad VPN on both the Linux desktop and GrapheneOS mobile, however, I did try disconnecting it on both devices but nothing really changed.

And when I was downloading with 13 Mb/sec, I was with Mullvad switched on. So it definitely worked with the VPN switched on.

Nothing makes sense any more.

Any input will be highly appreciated! Thank you!

13 Mbps (13 million bits per second) is actually quite slow, only about 1.5 Megabytes per second. IIRC you can click on the label to toggle the units.

You’re connected through a relay server in that screenshot, thus all traffic goes through the open internet. Said the two devices were in the same room? So you should be able to connect them directly via LAN. Check the firewalls on both, maybe preventing a direct connection. While they’re disconnected, you can see a list of addresses tried, including error messages for each that failed. That might give you a hint why direct connections fail.

Overall it seems like your internet uplink is unstable, dropping the connection to the relay server regularly. Might be worse when the VPN is involved.

Thanks a lot for the reply!

Yeah, relay or TCP LAN it’s the exact same issue and speed.

I found out that after restarting Syncthing I get a burst of speed for 15 sec, and then it just drops down to 0.

With dozens and dozens of restarting attempts I managed to get it to 99% and the last few files simply do not sync at all:

Regarding my overall internet speed, it’s completely and perfectly stable. We haven’t had an outage in years. I’m getting 700-800 Mb / sec Download and 80-90 Mb Upload speed. So a fairly fast internet connection.

But even on TCP LAN and with my Firewall disabled, Syncthing keeps dropping, it’s super slow and as you can see from the screenshot above cannot even complete the Sync.

I don’t even know where to begin troubleshooting. Nothing makes sense.

And I really, really want to get Syncthing to work properly without issues.

Start by looking at the logs, maybe on both sides, as they may tell you why it’s disconnecting.

Thanks a ton for your response!

The logs seem quite normal to me.

And as I said in my previous message, I managed to get it to sync normally by just brute forcing restarts and even reinstalling syncthing a few times.

My final problem now is that, the last 23 files simply do NOT get synced. No matter what I try.


And these files have no special permissions, or anything that might prevent them from syncing. They are a part of my Vault which is simply a mixture of photos and markdown notes.

So I have no idea why these 23 files simply do not want to sync. And even after deleting the synced folder, reinstalling Syncthing and re-trying to sync it again, the same 23 files are not synced.

What could be so special about these 23 .png and markdown notes?

Please post full screenshots of the Syncthing Web GUI on both sides. If there any “Failed items” listed in the folder on the receiving side, please click on them and include a screenshot from there too.

Thanks a lot for chiming in to help!

Here is the Desktop GUI:

And here are some of the Out of Sync items shown in the Desktop GUI. I couldn’t screenshot all of them because I have to scroll down. But they are all the same, meaning what’s shown in this screenshot is the same below the fold.

And the Mobile Web GUI is the following:

Thanks for the screenshots! We still need to see what it says when you click on the “23 items” in the mobile Web GUI.

However, from the provided information, I can say for sure that the file with <br> in its name isn’t going to be synced to Android, as its VFAT filesystem doesn’t allow the <> characters.

Ah great, your comment actually made me look into it and indeed all of these 23 filenames included one or more of the non-compatible with Android symbols.

So I renamed all of them, and it’s all good now on that front!

But unfortunately, I’m still dealing with these perpetual disconnects. There’s no rhyme or reason to them.

The Web GUI stays like this for 8-10 sec:

And then it switches to this for 1-2 sec:


And then it goes back to the disconnected state.

In an Android-based guide, I read that Syncthing-fork works better for Android. I doubted that, but since I’ve been banging my head against the wall for multiple days now, decided to give it a try. And it doesn’t. It’s the same exact issue.

Really wished to make Syncthing work… I love everything about it.

Your android operating system is most likely killing syncthing in the background to save battery and what not. Depending on the vendor of the OS there are different ways to try and exclude it.

Ok, after continuous troubleshooting and reading the Syncthing documentation, I believe I fixed my issues.

I advise anyone wanting to try Syncthing to really go through the documentation and forums to get at least a rudimentary understanding of how this piece of art works. Otherwise, you’ll most likely run into problems, simply due to ignorance.

My issue was resolved by split-tunnelling both Syncthing and the Syncthing Web GUI on my Linux desktop and the Syncthing app on my phone.

I tried split-tunnelling before even opening this topic, but my mistake was that I split-tunnelled only Syncthing via the terminal and using its PID. I didn’t also split tunnel the Web GUI.

Thanks for all of your help.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.