Syncthing keeps restarting. Scan never completes.

Linux (Debian) PC. v1.2.1, Linux (64 bit) Other devices: Windows 10 Laptop. v1.2.1, Windows (64 bit), Lenovo Tablet, Android v1.2.0

I’ve been running Syncthing successfully on these machines for some time syncing around 60 GiB. Yesterday all was running fine until the Linux box reported. Syncthing seems to be down, or there is a problem with your Internet connection. Retrying… Shortly after this the scan either restarts or drops back and this is happening at regular intervals so the scan never completes. The correct global state is reported and, as far as I can tell, so is the number of out of sync items. This number never changes unless I make a change on one of the other machines.

The other two devices are communicating quite happily.

I don’t think there is anything wrong with the network interface.

If more information would be useful please let me know.

Screenshots and logs would help. There’s several separate issues in your post. Well if I understand correctly, and the entire Syncthing process restarts, mostly logs.

If there are several separate issues they all started at the same time, possible I suppose.log-tail (3.1 KB) I attach the tail of the log file from the GUI, should you need more I can try and track down where the logs are stored on Debian. Please let me know if there’s anything specific that would be useful. I also attach a screen shot of the error message and one whilst Syncthing is running.

Screenshots look healthy (apart from the glaring issue in the first). As we need logs from the restart, you’ll have to get the from the system. On debian most likely you can get logs with journalctl -u syncthing@yourusername or if you run as a user service with journalctl --user -u syncthing.

I was told I needed to be a member of the group systemd-journal to use journalctl. After some research (I’m returning to Linux after a ten year gap) I edited /etc/group to add my username to the group. Now in response to

journalctl -u syncthing@myusername

I get:-

– Logs begin at Tue 2019-08-13 21:58:36 BST, end at Tue 2019-08-13 22:18:29 BST. – – No entries –

I couldn’t find the syncthing log in /var/log where I’d expect to find it. I’m beginning to lose the will to live. Can you help please?

How are you running syncthing? The logs are from the last 20mins strangely, so if it ran before that you might need to read up on journalctl how to look back further behind in time.

Sorry, stupid question: you have replaced yourusername with your actual username? Generally the important question is what Audrius asked: how do you run Syncthing.

I installed syncthing from the depository at https://apt.syncthing.net/ So I’m running it under my username not as a service.

I think the timings simply correspond to a reboot of the system and restarting syncthing. Running the command just now (yes, with my username) I get

– Logs begin at Tue 2019-08-13 21:58:36 BST, end at Tue 2019-08-13 23:13:27 BST. – – No entries –

So it’s timed to the present from the restart.

If you installed from there you must have run something like systemctl ebavle syncthing@user. Now the same service name should get logs with the command above. you can also try systemctl status syncthing@user. but really you need to determine how toy start/first enabled syncthing

I installed using the synaptic package manager. No further commands were needed.

I don’t know what synaptic package manager does, but it seems that logging is not setup properly, so you have to figure out how to fix that with synaptic people.

synaptic is merely a front end to the Debian package management programs, dpkg, apt etc. It installs deb packages, so how the program is set up is set in the deb package, ie by whoever maintains https://apt.syncthing.net/

We maintain that but absence of logs implies it did not run. Did you try checking the status of the service?

Just installing from apt does not run anything. It just puts everything in place, you still need to enable/start syncthing yourself.

I don’t know how. As I said, I’m returning to Linux after an absence of ten years. I’m rusty and my brain is ten years older! Can you advise please?

I start it from the kde desktop using the shortcut set up by apt synaptic.

In case of confusion, my first message above is a reply to Audrius, the second to Simon.

I’ve done some poking around this morning and have identified the cause of the problem although I’ve still no idea why the log isn’t being written as you expect it to be.

I ran this command in a shell

$ syncthing -no-browser -logfile=sync.log

and got this illuminating output to the console (but not to sync.log). log-crash (1.4 KB)

It also reveals where the syncthing logs are being written.

So I could have flaky hardware. I will rebuild the database and see what happens. Thank you both for your help.

1 Like

That’s the piece of crucial information that was missing to tell you how to get logs. Glad to see you worked it out :wink: