Syncthing is not run over the normal user

I have installed the syncthing properly but when I run the syncthing under standard user on centos it give output of failure

[start] 18:25:27 WARNING: Error opening database: resource temporarily unavailable (is another instance of Syncthing running?) [monitor] 18:25:27 INFO: Syncthing exited: exit status 1 [monitor] 18:25:28 WARNING: 4 restarts in 4.086225951s; not retrying further

it works fine with root. how do I solve it?

As the error message suggests, syncthing believes there is already an instance of syncthing running as that user.

It works for root because root is a different user, hence the database lives in a different location.

1 Like

Great, but the assumption was wrong, the syncthing is not running and the GUI portal is not accessible ?

How have you verified that it’s not running?

The fact that the UI is not available doesn’t mean it’s not running.

On first startup, if the default port was taken (for example because it was used by syncthing running as root), it would have picked a different random port.

The UI address is printed in the logs as it starts up.

1 Like

I list the process running with ps aux |grep syncthing AND netstat antp |grep 8384 but there is no syncthing running

I have issue for that, since syncthing keeps changing the port on VM as follow

ps aux |grep syncthing root 8448 0.0 0.0 112808 972 pts/0 S+ 19:46 0:00 grep --color=auto syncthing [root@thirsty-diffie SieraAdmin]# ps aux |grep syncthing root 8565 0.0 0.0 112808 972 pts/0 S+ 19:47 0:00 grep --color=auto syncthing [root@thirsty-diffie SieraAdmin]# ps aux |grep syncthing root 8736 0.0 0.0 112808 968 pts/0 S+ 19:48 0:00 grep --color=auto syncthing [root@thirsty-diffie SieraAdmin]# ps aux |grep syncthing root 8747 0.0 0.0 112808 972 pts/0 S+ 19:48 0:00 grep --color=auto syncthing

The goal is to run Syncthing on startup or boot level, I’m trying to add boot up script to run the Syncthing, that is not worked.

the step needs to solve

  1. Run syncthing (standard user)
  2. run syncthing on bootup as cron job with (running user either root or standard)

You didn’t specify which version of Centos you’re using. For Centos 8 you can setup a systemd service following our documentation.

CentOS Linux release 7.9.2009 (Core)

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.