Syncthing is disabled - 2nd update and no go

Hi all, On my note Samsung Note 20, two updates ago syncthing worked perfectly and I was verily happy. Then at some stage an update occured and it no longer runs - well does anything useful. I get the following message on the bootup:

“Syncthing is disabled Do you want to change the run conditions? Reasons: Not connected to WiFi (A Config file crucial to operation is missing)”

So when I go to change settings, The only checked box is “Run of WiFi”. When I select “Run on moblie data” it starts to perform but I want it to run only on wifi for obvious reasons. I have trauled the Net for quite some time and no help so asking here. Any info would be muchly appreciated. Oh and “Run on specified Wi-Fi networks” reports “run on all networks”. When I select this to change, I’m told to “connect to a Wi-Fi to add it to the list”. Thanks again.

Oh and I notice the new 1.18 version is now available an hour after I updated to 1.17 lol. Google play has not got it yet…

App Version: 1.17.0
Syncthing Version: ?? Won't say
Android Version: Android 11

You’ve not stated under which conditions you’d like Syncthing to run so I can’t be sure what you’re trying to achieve. If your settings seem to be corrupt in some way there’s a backup feature which will export the underlying Syncthing settings (but not the app-specifics) - you could take a backup, then reinstall the app to be sure you’ve erased any possible corruption, then import the backup.

1 Like

Fair enuff so here goes.

A Samsung Note 20 syncs to a Windows10 laptop when both are on the home WiFi with only the photos folder and 2 image folders.

I have uninstalled Syncthing several times and still the same problem persists. Syncthing refuses to see the wifi (on the phone) and there are no settings that I can see to force it. Around and around.

You potentially need to manually grant it location permissions. Wifi names are considered location revealing, hence require location permissions.

Also, need to make sure location services are enabled.

2 Likes

Done and done. Full location all the time and WiFi scanning for greater accuracy.

Still same message. I’m starting to understand that Android 11 is a bit of a stickler for this.

If it still doesn’t work. I don’t have much to suggest. Probably the vendor ROM is doing something weird, or Android 11 broke things the way we access them.

1 Like

Much Appreciate your help.

SHame too. was working perfectly :frowning:

Cleared everything, re setup on laptop and phone all folders etc. and works fine on phone data but refuses to run or even get into operation menus when wifi selected. Just refuses to connect

Solved. :slight_smile: For some reason the “Saved Networks” menu on the phone settings was showing my local WiFi as not connected even though it was. I selected it in the list, it became active and finally, done. I’ll leave this here for any one else in the same straights - too many opotions for the elderley. :wink:

4 Likes