Syncthing getting only 1.5MBps


(Kris) #1

Hi all, I am using android and a linux server to sync and getting only ~1.5mega bytes per second. They both have direct connection per the ‘address’ key under each device. Both devices are showing less than 5% CPU usage. I opened up both of the ports on the server 22000 tcp and 21027 udp. Any other ideas? (running syncthing via systemd on the server).

Thanks


(Audrius Butkevicius) #2

If it’s many small files, the overhead per file might be too much.


(Kris) #3

Thanks for getting back to me. They are around 1-2MB per file. Another question, can the ‘ignore_delete’ option be requested sent to another peer? In my case I would like the server to auto accept folders and also set the ‘ignore_delete’ flag.


(Audrius Butkevicius) #4

No, options are local to your device. Perhaps the network connection is just latient or slow hence why you get bad throughput.


(Kris) #5

Thanks. If there is any other way of setting ignore_delete by default or set versioning by default please do let me know. I will try to figure out the networking issues.


(Audrius Butkevicius) #6

There is no way to set these by default. You could potentially try to call rest API to set them up on all folders periodically or something like that, but that will require scripting from your side.


(Kris) #7

Thanks you may mark this as solved.