Syncthing crashing after updating to v1.27.1 / Windows 7 / runtime.asmstdcall()

Can you help me a bit with this please, I’m a dumbass, on my Win7 machine: AppData\Roaming\SyncTrayzor\config.xml what do I need to do?

here is the content of the xml:

<?xml version="1.0"?>
<Configuration xmlns:xsd="" xmlns:xsi="" Version="10">
  <SyncthingCommandLineFlags />
  <SyncthingEnvironmentalVariables />
  <Folders />
    <MinPosition>-32000, -32000</MinPosition>
    <MaxPosition>-1, -1</MaxPosition>
    <NormalPosition>290, 155, 1100, 700</NormalPosition>
  <SyncthingCustomPath />
  <SyncthingCustomHomePath />
  <OpenFolderCommand>explorer.exe "{0}"</OpenFolderCommand>
  <ShowFileInFolderCommand>explorer.exe /select, "{0}"</ShowFileInFolderCommand>

The Synchting is not showing me a version, says: Unknown

Probably set this to true instead of false, and replace the Syncthing binary with syncthing.exe.old (if there is one) or from Release v1.27.0 · syncthing/syncthing · GitHub

I don’t really know how to do that in practice, but if someone wants to iron it out and contribute + maintain it that’d be awesome I’m sure.

1 Like

I’ve faced to the same problem on Windows 7 after recent upgrade. I solve it next way: 0) save my previous SyncTrayzorPortable-x64 folder.

  1. download the last portable SyncTrayzor tool: Releases · canton7/SyncTrayzor · GitHub.
  2. replace SyncTrayzorPortable-x64 folder with downloaded at step 1.
  3. copy SyncTrayzorPortable-x64\data folder from previous installation.
  4. turn off upgrades in config: SyncTrayzorPortable-x64\data\syncthing\config.xml 0
  5. download the last working in Win7 version: Release v1.27.0 · syncthing/syncthing · GitHub and replace files with downloaded one: SyncTrayzorPortable-x64\syncthing.exe SyncTrayzorPortable-x64\data\syncthing.exe

After that I started SyncTrayzor.exe and it got all my saved configuration. Now, it works as expected.

1 Like

My experience with the same problem.

I am syncing with SyncTrayzor between two machines, one with win11(no prob, upgrated to Syncthing v1.27.1 fine) and the other with Win7 (also autoUpgrated to v1.27.1 from 1.27.0, just a few hours ago and stopped working).

Changing the autoUpgrade to 0 was easy in the config.xml file located on the path C:\Users\myname\AppData\Local\Syncthing where the %LOCALAPPDATA%\Syncthing will take you.

But finding the syncthing.exe.old file is not straightforward and the syncthing.exe file located in normal \ProgramFiles\ directory is not used by SyncTrayzor. The upgraded versions of syncthing.exe and syncthing.exe.old are located in this directory: C:\Users\myname\AppData\Roaming\SyncTrayzor and that .exe is executed when SyncTrayzor is running.

In the same directory you can find the config.xml file for the SyncTrayzor, if you mess up(like me) the settings of SyncTrayzor and doesn’t run anymore.

Also, for anyone who doesn’t know it, you can run syncthing.exe (from any path) as a standalone app and will open the GUI in the default browser. No need for SyncTrayzor or other front end.

Hi Thank you it worked. But I have lost folder set up I previously had. I messed it up so badly since yesterday. Is there anyway I can re-instate the sync folders again? Sorry I have never used this application in my previous organizations and this is the first time I’m facing this issue. Thanks in advance.

of course, just reconfigure the folder in synchfing.
for example, a request comes from a remote system to connect a folder, accept it and specify its location on local media

But I’m using the installed version on win7 machine, whatever I do it keeps upgrading to latest version and stops working.

Would it be easier to uninstall the current one, install 1.27.0 and just setup it again? (I only sync 3 folders anyway)

hi, where on earth did you manage to change the autoUpgrade to 0 in the?: C:\Users\myname\AppData\Local\Syncthing

        <minHomeDiskFree unit="GB">1</minHomeDiskFree>

That would be the “autoUpgradeIntervalH”.


This is a totall disaster, We have one feeder and 27 machines listening to it ( win 7 and win10). The update is so agressive and despite of all the help ( thnks boys and girls) It looks like we can;t fix it properly.

Isseems to work and the… nope. We did all the things even set on the feeder machine the environment variables.

Is there anyone who can build a patch? So all the machines will go back to the 5th of december running version 1.27.

All my machines (27) autmatically reboot at 4 am and i’m afraid that i will be back to square 1

Does anyone know what happens if WE UPGRADE the old feeder machine w7 to Windows 10? I sure don’t want to loose all the machine configs. Rebuilding 27 machines is not an option,

Appreciate your help

As kkontak notes, I’ve always used syncthing as a standalone app from the download folder on a Windows 7 machine. To fix the current issue with the update that occurred to the app, I opened the config.xml file in C:\Users[username]\AppData\Local\Syncthing with Wordpad and made 2 changes: changed the value for “autoUpgradeIntervalH” from 12 to 0; changed the value for “configuration value” from 37 to 35, because the syncthing.log file in the same directory path folder following the auto upgrade said “config file version (37) is newer than supported version (35).” Following these changes, my older version (1.16.1) now works again on Windows 7.

That’s roughly the process, but 1.16.1 is several years old. You could at least run 1.27.0 and be a lot better off.

1 Like

Hi @pfg21 Thanks. Sorry I havent used Synctrayzor before. I need to sync only specific files from a folder in Windows machine to linux. Are there any tutorials on Youtube that I can refer to? I tried to search and could not understand. If possible could you explain with steps? Sorry for asking too much. Thanks.

I can confirm that 1.27.0 works fine on Win 7-Pro. I originally started back at 1.16.1 then stepped up with downloaded versions to 1.27.0…works like a champ.

:slight_smile: similarly, I don’t use synctrayzor.
I use non-sucking-service-manager to run syncthing as a win7 service. I have not found any other adequate program for win7 :-/

in this case, I just replace the executable file syncthing.exe with a new file from the install archive.

I came accross this because i am migrating from an old windows server to linux and need syncthing to keep files in sync on new server.

For those on windows 7, Personally i would just install Windows 10 and be done with it … you can use windows 10 without licensing and it only puts a small overlay in bottom right of screen and disables access to a few options, thats it, fully usable without paying for windows license key.

Be careful with that though. Even though technically the OS does work, it’s still against the EULA. If it’s a home computer, yeah, no-one will care, but on a work machine, it’s no different than using a pirated copy of Windows.

However, if the Windows 7 copy is legitimate, then you can still upgrade to Windows 10 using the same license/serial key and it should activate just fine. Unless the computer is extremely old, Windows 10 should work on the same hardware (except for rare driver incompatibilities). Have done this myself even on a 15-year-old laptop.

Unfortunately that’s not true anymore. You could do that for the past 8 years, yes, but Microsoft shut off activations of Win 7/8 product keys on Win 10+11 recently. They also killed off the upgrade path via the upgrade conversion tool that did an in-place upgrade of a Win 7 machine to a Win 10 machine.

Oops, I’m sorry for spreading outdated information :sweat:. This is a real problem then, as Windows 11 does have much higher hardware requirements (which can be circumvented but for how long?), and buying a new copy of Windows 10 when its support ends in less than 2 years doesn’t make much sense.

1 Like