Syncthing crashing after updating to v1.27.1 / Windows 7 / runtime.asmstdcall()

It does care but unless you are running an extremely old version, you should be fine for the upcoming months, if not years.

2 Likes

That’s hard to predict. But your operating system isn’t getting security updates either any more, so this seems like an odd concern under the circumstances?

3 Likes

Touché! :wink:

1 Like

Perhaps syncthing could use some mechanism to identify what OS versions are compatible with future upgrades before those upgrades are done automatically. I have a system offline for a few days that is likely affected. Have to check up on what is that system is running. Yes I know windows 7 is beyond support. But we run some old hardware in some of these old systems that for valid reason is not easy to upgrade (and in some cases impossible…)

Anyway just a thought.

1 Like

I will assume quite a long time :slight_smile: until there are changes in the data exchange format, and they are quite stable.
An outdated version of resilio or syncthing (can’t remember which one specifically) worked for quite a long time on WinXP.
I’m leaving 1.27.0 and disabling updates. let’s see what the future holds.

@calmh Maybe we should add in the description of version 1.27.0 that it is the “last that works on Windows 7”.

Same problem. I’m syncing win10 to win7 and vice-versa, it no longer works . Is there a link to an older version to install to win7 machine or any other way?

The previous releases are available at Releases · syncthing/syncthing · GitHub

Click on the desired version and you’ll find the code as well as the executables for a dozen of platforms, including Windows. Just make sure to set --no-upgrade as argument, or it may automatically upgrade again.

4 Likes

I had to edit the config file to change the prerelease flag from true to false, saved then reopened St using an earlier version (1.27). The go into settings and told it to no longer do any updates (on W7 devices).

It will then sync as before

1 Like

Can you help me a bit with this please, I’m a dumbass, on my Win7 machine: AppData\Roaming\SyncTrayzor\config.xml what do I need to do?

here is the content of the xml:

<?xml version="1.0"?>
<Configuration xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" Version="10">
  <ShowTrayIconOnlyOnClose>false</ShowTrayIconOnlyOnClose>
  <MinimizeToTray>false</MinimizeToTray>
  <CloseToTray>true</CloseToTray>
  <ShowDeviceConnectivityBalloons>false</ShowDeviceConnectivityBalloons>
  <ShowDeviceOrFolderRejectedBalloons>true</ShowDeviceOrFolderRejectedBalloons>
  <ShowSynchronizedBalloonEvenIfNothingDownloaded>false</ShowSynchronizedBalloonEvenIfNothingDownloaded>
  <SyncthingAddress>localhost:8384</SyncthingAddress>
  <StartSyncthingAutomatically>true</StartSyncthingAutomatically>
  <SyncthingCommandLineFlags />
  <SyncthingEnvironmentalVariables />
  <SyncthingDenyUpgrade>false</SyncthingDenyUpgrade>
  <SyncthingPriorityLevel>AboveNormal</SyncthingPriorityLevel>
  <Folders />
  <NotifyOfNewVersions>true</NotifyOfNewVersions>
  <ObfuscateDeviceIDs>true</ObfuscateDeviceIDs>
  <UseComputerCulture>true</UseComputerCulture>
  <SyncthingConsoleHeight>231</SyncthingConsoleHeight>
  <WindowPlacement>
    <IsMaximised>true</IsMaximised>
    <MinPosition>-32000, -32000</MinPosition>
    <MaxPosition>-1, -1</MaxPosition>
    <NormalPosition>290, 155, 1100, 700</NormalPosition>
  </WindowPlacement>
  <SyncthingWebBrowserZoomLevel>0</SyncthingWebBrowserZoomLevel>
  <LastSeenInstallCount>0</LastSeenInstallCount>
  <SyncthingCustomPath />
  <SyncthingCustomHomePath />
  <DisableHardwareRendering>false</DisableHardwareRendering>
  <HideIntelXeWarningMessage>false</HideIntelXeWarningMessage>
  <EnableFailedTransferAlerts>true</EnableFailedTransferAlerts>
  <EnableConflictFileMonitoring>true</EnableConflictFileMonitoring>
  <ConflictResolverDeletesToRecycleBin>true</ConflictResolverDeletesToRecycleBin>
  <PauseDevicesOnMeteredNetworks>true</PauseDevicesOnMeteredNetworks>
  <HaveDonated>false</HaveDonated>
  <IconAnimationMode>DataTransferring</IconAnimationMode>
  <OpenFolderCommand>explorer.exe "{0}"</OpenFolderCommand>
  <ShowFileInFolderCommand>explorer.exe /select, "{0}"</ShowFileInFolderCommand>
  <LogLevel>Info</LogLevel>
</Configuration>

The Synchting is not showing me a version, says: Unknown

Probably set this to true instead of false, and replace the Syncthing binary with syncthing.exe.old (if there is one) or from Release v1.27.0 · syncthing/syncthing · GitHub

I don’t really know how to do that in practice, but if someone wants to iron it out and contribute + maintain it that’d be awesome I’m sure.

1 Like

I’ve faced to the same problem on Windows 7 after recent upgrade. I solve it next way: 0) save my previous SyncTrayzorPortable-x64 folder.

  1. download the last portable SyncTrayzor tool: Releases · canton7/SyncTrayzor · GitHub.
  2. replace SyncTrayzorPortable-x64 folder with downloaded at step 1.
  3. copy SyncTrayzorPortable-x64\data folder from previous installation.
  4. turn off upgrades in config: SyncTrayzorPortable-x64\data\syncthing\config.xml 0
  5. download the last working in Win7 version: Release v1.27.0 · syncthing/syncthing · GitHub and replace files with downloaded one: SyncTrayzorPortable-x64\syncthing.exe SyncTrayzorPortable-x64\data\syncthing.exe

After that I started SyncTrayzor.exe and it got all my saved configuration. Now, it works as expected.

1 Like

My experience with the same problem.

I am syncing with SyncTrayzor between two machines, one with win11(no prob, upgrated to Syncthing v1.27.1 fine) and the other with Win7 (also autoUpgrated to v1.27.1 from 1.27.0, just a few hours ago and stopped working).

Changing the autoUpgrade to 0 was easy in the config.xml file located on the path C:\Users\myname\AppData\Local\Syncthing where the %LOCALAPPDATA%\Syncthing will take you.

But finding the syncthing.exe.old file is not straightforward and the syncthing.exe file located in normal \ProgramFiles\ directory is not used by SyncTrayzor. The upgraded versions of syncthing.exe and syncthing.exe.old are located in this directory: C:\Users\myname\AppData\Roaming\SyncTrayzor and that .exe is executed when SyncTrayzor is running.

In the same directory you can find the config.xml file for the SyncTrayzor, if you mess up(like me) the settings of SyncTrayzor and doesn’t run anymore.

Also, for anyone who doesn’t know it, you can run syncthing.exe (from any path) as a standalone app and will open the GUI in the default browser. No need for SyncTrayzor or other front end.

Hi Thank you it worked. But I have lost folder set up I previously had. I messed it up so badly since yesterday. Is there anyway I can re-instate the sync folders again? Sorry I have never used this application in my previous organizations and this is the first time I’m facing this issue. Thanks in advance.

of course, just reconfigure the folder in synchfing.
for example, a request comes from a remote system to connect a folder, accept it and specify its location on local media

But I’m using the installed version on win7 machine, whatever I do it keeps upgrading to latest version and stops working.

Would it be easier to uninstall the current one, install 1.27.0 and just setup it again? (I only sync 3 folders anyway)

hi, where on earth did you manage to change the autoUpgrade to 0 in the?: C:\Users\myname\AppData\Local\Syncthing

<options>
        <listenAddress>default</listenAddress>
        <globalAnnounceServer>default</globalAnnounceServer>
        <globalAnnounceEnabled>true</globalAnnounceEnabled>
        <localAnnounceEnabled>true</localAnnounceEnabled>
        <localAnnouncePort>21027</localAnnouncePort>
        <localAnnounceMCAddr>[ff12::8384]:21027</localAnnounceMCAddr>
        <maxSendKbps>0</maxSendKbps>
        <maxRecvKbps>0</maxRecvKbps>
        <reconnectionIntervalS>60</reconnectionIntervalS>
        <relaysEnabled>true</relaysEnabled>
        <relayReconnectIntervalM>10</relayReconnectIntervalM>
        <startBrowser>true</startBrowser>
        <natEnabled>true</natEnabled>
        <natLeaseMinutes>60</natLeaseMinutes>
        <natRenewalMinutes>30</natRenewalMinutes>
        <natTimeoutSeconds>10</natTimeoutSeconds>
        <urAccepted>-1</urAccepted>
        <urSeen>3</urSeen>
        <urUniqueID></urUniqueID>
        <urURL>https://data.syncthing.net/newdata</urURL>
        <urPostInsecurely>false</urPostInsecurely>
        <urInitialDelayS>1800</urInitialDelayS>
        <autoUpgradeIntervalH>0</autoUpgradeIntervalH>
        <upgradeToPreReleases>false</upgradeToPreReleases>
        <keepTemporariesH>24</keepTemporariesH>
        <cacheIgnoredFiles>false</cacheIgnoredFiles>
        <progressUpdateIntervalS>5</progressUpdateIntervalS>
        <limitBandwidthInLan>false</limitBandwidthInLan>
        <minHomeDiskFree unit="GB">1</minHomeDiskFree>
        <releasesURL>https://upgrades.syncthing.net/meta.json</releasesURL>
        <overwriteRemoteDeviceNamesOnConnect>false</overwriteRemoteDeviceNamesOnConnect>
        <tempIndexMinBlocks>10</tempIndexMinBlocks>
        <trafficClass>0</trafficClass>
        <setLowPriority>true</setLowPriority>
        <maxFolderConcurrency>0</maxFolderConcurrency>
        <crashReportingURL>https://crash.syncthing.net/newcrash</crashReportingURL>
        <crashReportingEnabled>true</crashReportingEnabled>
        <stunKeepaliveStartS>180</stunKeepaliveStartS>
        <stunKeepaliveMinS>20</stunKeepaliveMinS>
        <stunServer>default</stunServer>
        <databaseTuning>auto</databaseTuning>
        <maxConcurrentIncomingRequestKiB>0</maxConcurrentIncomingRequestKiB>
        <announceLANAddresses>true</announceLANAddresses>
        <sendFullIndexOnUpgrade>false</sendFullIndexOnUpgrade>
        <connectionLimitEnough>0</connectionLimitEnough>
        <connectionLimitMax>0</connectionLimitMax>
        <insecureAllowOldTLSVersions>false</insecureAllowOldTLSVersions>
    </options>

That would be the “autoUpgradeIntervalH”.

See: https://docs.syncthing.net/v1.27.0/users/config#config-option-options.autoupgradeintervalh

This is a totall disaster, We have one feeder and 27 machines listening to it ( win 7 and win10). The update is so agressive and despite of all the help ( thnks boys and girls) It looks like we can;t fix it properly.

Isseems to work and the… nope. We did all the things even set on the feeder machine the environment variables.

Is there anyone who can build a patch? So all the machines will go back to the 5th of december running version 1.27.

All my machines (27) autmatically reboot at 4 am and i’m afraid that i will be back to square 1

Does anyone know what happens if WE UPGRADE the old feeder machine w7 to Windows 10? I sure don’t want to loose all the machine configs. Rebuilding 27 machines is not an option,

Appreciate your help

As kkontak notes, I’ve always used syncthing as a standalone app from the download folder on a Windows 7 machine. To fix the current issue with the update that occurred to the app, I opened the config.xml file in C:\Users[username]\AppData\Local\Syncthing with Wordpad and made 2 changes: changed the value for “autoUpgradeIntervalH” from 12 to 0; changed the value for “configuration value” from 37 to 35, because the syncthing.log file in the same directory path folder following the auto upgrade said “config file version (37) is newer than supported version (35).” Following these changes, my older version (1.16.1) now works again on Windows 7.