Syncthing 1.4.0 and SyncTrayzor 1.1.24

I am trying to use Syncthing 1.4.0 with SyncTrayzor 1.1.24 on Windows 10. I believe these are the latest versions. They do not seem to work together. Syncthing does not start with SyncTrayzor.
Has anybody else got these working together? If so some advice on what I am likely to be doing wrong would be appreciated. The error message is “failed to start Syncthing.” The log says “WARNING: Failed to initialize config: Config file version (30) is newer than supported version (29). If this is expected, use -allow-newer-config to override.” Many thanks, Chris

These versions work just fine together, running these with no issues here.

The message you posted indicates that you’re trying to run an older syncthing version (e.g you’ve downgraded), which is disabled for safety reasons.

SyncTrayzor bundles it’s own syncthing.exe and that generally isn’t always up to date, so if you installed SyncTrayzor on top of a working syncthing installation that results in a downgrade. As for a fix, just replacing SyncTrayzor’s syncthing.exe with the latest version (1.4.0) should fix it.

The SyncTrayzor-bundled syncthing.exe is located in two directories:

  • <Path\to\SyncTrayzor\ (e.g C:\Program Files\SyncTrayzor), syncthing.exe
  • %AppData%\SyncTrayzor, syncthing.exe

One of the two is just used for backup purposes (so that there’s something to rollback too), but I can’t remember which one.

@canton7 while we’re on topic, Syncthing v1.4.0 has bumped the config version from 29 to 30. Maybe updating the bundled version would be useful now?

Brilliant - thank you Nummer378, that worked. I must have had an old version in one of those locations. Many thanks for your help.

Chris

My country recently went into lockdown-lite, and my company can’t figure out where I should be working from. I’m afraid I have zero spare time for things like hobby projects at the moment!

Hope your work situation improves soon, for your sake