syncthing 0.14.20 wont start - FATAL

After upgrading to 0.14.20 today syncthing won’t start.

Logfile just repeats:

FATAL: -logfile may not be used with -no-restart or STNORESTART

My start command line is:

syncthing -logflags=3 -logfile=/home/mc/logfile/syncthing.log -no-browser

ie not using no-restart.

config file has:

restartOnWakeup>true /restartOnWakeup

which doesn’t seem relevant.

Can see from the release notes for 0.14.20

Using -logfile flag together with -no-restart now causes an error instead of silently failing.

however I don’t seem to be using no-restart. An error?

(should have added am on a laptop running Kubuntu 14.04 Was working ok yesterday on 0.14.19. Happens the same on two laptops.)


You must have STNORESTART=1 somewhere in the environment?

Not in config.xml, not in the startup line.

Same problem here on Windows Server 2012 R2 since version 0.14.20.

also getting this after upgrading from 0.14.19 running on Slackware64 14.2 Linux kernel 4.4.44

1 Like

I have the same issue on my Windows Server 2012 R2 machines. Version 4.19 was fine. I am running Syncthing as a service configured by nssm. If I run the executable directly without command line arguments, it launches fine, but I’d really like this to run as a service with the logfile specified.

1 Like

If I run the executable directly without command line arguments, it launches fine

Thanks Matthew - that gives me a workaround till this is fixed. At least I can run it now. I’m guesing there is no log by default, but I can see what is happening in the command line window.

I’ll drop a .21 with a fix now in the morning.

1 Like

Okay, try the 0.14.21 just released. If it doesn’t upgrade automatically because it doesn’t start, run

syncthing -upgrade

from a command prompt.


Thank you! This is working as expected now.

confirmed working on Slackware64 14.2 and 0.14.21

In my privileged position as the OP (joke) I can confirm 0.14.21 works for me also.

I can also add that it is the end of a unique episode: 2 days of Syncthing not working fully: 1 day because of 0.14.19 on Android the next day because of 0.14.20 on the desktop.

My windows batch looks like this:

@start “Syncthing” /low syncthing.exe -no-console -no-browser -home=“E:\settings\Syncthing” -logfile=“E:\settings\Syncthing\syncthing.log”

(reading the config from E:…)

Is it fine to start syncthing like told above? (syncthing.exe -upgrade) or should I add the settings-path?

I don’t want to have files mixed up where they don’t belong.

Or will it be the simlest thing just to download the new syncthing version and replace the executable by hand?

Answering my questions myself, sorry, for asking the obvious.

Syncthing is such a great tool, the upgrade process just upgrades the executable and does nothing more. (I was sceptic, if the upgrade process would start syncthing and the whole process of syncing…)

For Windows: E:\syncthing-windows-amd64>syncthing.exe -upgrade 14:01:18 INFO: Upgrade available (current “v0.14.20” < latest “v0.14.21”) 14:01:27 INFO: Upgraded to “v0.14.21”

And my Synology Box: /var/packages/syncthing/target/bin# ./syncthing -upgrade 13:59:09 INFO: Default folder created and/or linked to new config 13:59:09 INFO: Upgrade available (current “v0.14.20” < latest “v0.14.21”) 13:59:16 INFO: Upgraded to “v0.14.21”

Thanks for such a pleasurable service :wink:


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.