Syncing with 2 masters?

Dear SyncThing-community,

I’ve just managed to get SyncThing work with my Windows 10 PC, my Windows 10 Laptop and my phone and primarily use it to sync my whole music database (about 60GB).

Syncing with my phone works fine, but right now I’m trying to get something work with my PC and Laptop. Here’s the issue:

I’m using my PC (let’s call it A for now) for my primary music database and use my Laptop (B) for DJing purposes (using Traktor v3.2.0). That means I want to transfer songs from A to B and have the changes I made in B transfer back to A and so on depending on what I want to change (metadata on A or B for organizing purposes, global gain settings etc).

Right now I set my A as master and read-only and my B to write-only, but as soon as I set both to read and write I get many sync-errors on A and B and it eats up my disk space. Any possibilities how to set it up properly?

Master and read only, what does that mean?

It seems that you want A to sync to B and B to sync to A, so it’s not clear why don’t you just have send-receive on both sides?

If I enable send-receive on both sides, I get lots of sync-conflict files and it doesn’t really sync the changes. That’s my problem right now

That just means that the files are not the same on both sides.

Yes they are edited by some bits because I load them up in Traktor for editing e.g. cue points and Traktor saves this information in the file… I only want the edited files from B to be transferred to A (overwriting them if possible) so that these files are all in sync.

Then set B to send only, and press override changes (which will force A to accept the view like it looks like on B).

Done that, but A won’t accept the overridden changes… It only says out of sync and as soon as I override on A B says out of sync and so on

What folder type is A setup as? If it’s set to send-only then it clearly won’t work, as two send only folders means nobody is accepting anything.

You should check on A what it says in the UI, perhaps some failed items. If you can’t it out, post a screenshot

Bingo, found the culprit. It was set so send-only first, edited it to send and receive. My changes successfully got applied to A. Thank you!