Syncing Files from PC to Google TV (Android 11) via USB Drive?

I can sync things between my PC and TV local storage without any issues, but I am unable to make it work with external storage. I received a warning stating,

“Your Android version does not allow syncing to external storage devices.”

After researching in the community, people mentioned that this issue persists until Android 10, but it has been resolved in Android 11 and beyond.

(Via u/decipher90

If the device is android 10 or below, syncthing will have issues accessing external storages due to android SAF limitations, Android 11 and 12 work fine for me.

Reddit - Dive into anything

However, I am still facing difficulties.

Here’s what I have tried so far (apart from the basic):

  • Formatted the external drive as a device storage.

  • Enabled “Force allow apps on external” in developer options.

  • In the Syncthing settings, I enabled the advanced folder picker, but it didn’t work at all.

Is it related to the fact that Syncthing was written in Golang, causing the “Android Storage Model Limitations” compatible issue, or is there anything I have missed or done wrong? Please help.

(Note: I do not want to root the TV just yet to make it work because I recently bought it. Yes, I can use Kodi or Jellyfin to access content from my PC to the TV, which I’m doing but I am looking for a way to make the external storage devices work with Syncthing on my Android 11 Google TV.)

(Posted the same question on Reddit)

Please screenshots of the exact messages that you’re seeing. On Android 11 and newer, you should be able to gain access to a particular folder by using the file picker launched from the Syncthing app which should automatically open when trying to select a new folder to sync. If that doesn’t happen, then you may need to install a 3rd party file explorer (e.g. Material Files from F-Droid) first.

The basic idea is that you need to navigate to the folder in question through the file picker (i.e. the file explorer app that should open automatically) and then grant it access to that folder. Only then, Syncthing will be able to use the folder.

(Side note: I think we really should have some kind of a visual tutorial in the Docs for this specific case, as the question comes up a lot. I may try to come up with something myself if no-one else does it before me).

You should also check Android permissions for the Syncthing app and make sure that “all files access” is enabled.

1 Like

First of all, thanks for your detail response.

Please screenshots of the exact messages that you’re seeing.

then you may need to install a 3rd party file explorer (e.g. Material Files from F-Droid) first

I have installed “TV File Commander” from TV PlayStore. Strangely the “TV File Commander” can read/write to the external drive just fine but not Syncthing.

You should also check Android permissions for the Syncthing app and make sure that “all files access” is enabled.

I have not found any other options in setting, only got the below option in apps setting related to files access, and have enabled it.

(Side note: I think we really should have some kind of a visual tutorial in the Docs for this specific case, as the question comes up a lot. I may try to come up with something myself if no-one else does it before me).

It is so nice of you to help the community.

Please help.

I still think you should try using another file manager. This is what you basically need to see:

and then upon pressing the “use this folder” button you will be presented with a pop-up asking you to allow Syncthing access to the folder.

At the moment, your “Folder Picker” screenshot only displays folders on the internal storage (i.e. /storage/emulated/0) with no option to switch to the SD card, and also no option to ask for access to a specific folder.

I still think you should try using another file manager. This is what you basically need to see:

I installed the Material Files (and given all the necessary permissions and it can read/write the external device without any issue)

and then upon pressing the “use this folder” button you will be presented with a pop-up asking you to allow Syncthing access to the folder.

But when I click the directory button in Syncthing, the Syncthing’s default Folder Picker appears (not any pop up for Material Files) and getting the same error,

Having said that * In the Syncthing settings, I enabled the advanced folder picker, Still the Material Files manager wont open through Syncthing.

:confused:

It seems like its a bug with Syncthing

You do need to have the advanced folder picker option enabled for Material Files to show up. However, judging from the screenshots, the OS seems to always launch the very limited default file picker, which doesn’t support anything newer than Android 4.4 (see https://github.com/syncthing/syncthing-android/issues/1850).

Yeah, I saw that issue some time ago and posted a bump comment there. I don’t know why they collapsed that comment as as off-topic Lol. Anyways, @Catfriend1 fixed the issue; it should be fixed if the Syncthing folks pull that fix to the release branch, right?

In general, bumps are frowned upon, because if the issue is still open, this on its own already means that the problem hasn’t been fixed yet. In this case, yes, someone should probably port the fix from the Fork. However, because the official Syncthing app is in maintenance mode, we need a volunteer to do it.

1 Like

Hi tomasz86

Finally, I’m able to transfer data to my Google TV via Syncthing, but only to this particular location:

My USB Drive/Android/data/com.nutomic.syncthingandroid/files

It’s sending and receiving data just fine from PC to TV. However, now this workaround has a significant drawback.

The files that are synced to the

My USB Drive/Android/data/com.nutomic.syncthingandroid/files

location cannot be accessed. I tried with the built-in media player, Material File Explorer, etc., but they all refuse to access the folder from that USB drive. Here’s a screenshot.

Do you have any solutions for this issue?

It’s rough. Unless the app is fixed and the file picker is made compatible with newer Android versions, the only other suggestion would be to try rooting the device and then running Syncthing as root. This may allow it to access those restricted locations. No guarantee before you actually try doing it though.

:frowning: Okay

You could try the /media/ path instead of the data path. It should be visible to other apps.

E.g. mine is: /storage/emulated/0/Android/media/com.github.catfriend1.syncthingandroid.debug

Thanks for your responce,

E.g. mine is: /storage/emulated/0/Android/media/com.github.catfriend1.syncthingandroid.debug

But what’s the point of storing it inside the media folder if it’s not able to be synced through Syncthing? Because in the Syncthing folder picker, it only tells to store inside the data folder (please refer to the screenshot below) Or am I missing something here?

Well , just try it. Data is not seen by Androids gallery scanner, media is. I have had phones were media was writeable but every phone (rom) is different :slightly_smiling_face:.

1 Like

Yes, I can access the media folder with a file manager just fine. But how can I make Syncthing let me pick inside the media folder instead of the data folder? Otherwise, it won’t make any sense, right?

1 Like

You may try to input the path manually and see what happens. This can be done using the Web GUI (available from the left slide-out menu).

2 Likes

You may try to input the path manually and see what happens. This can be done using the Web GUI (available from the left slide-out menu).

@tomasz86

That’s exactly where the solution lies. When I initially used the WEB GUI, it was choppy to control with the TV remote, so I dropped it. Now, when you suggested it, I connected my wireless mouse and keyboard to the TV and tried again. As suggested by you, I manually tried to add the location. Voila! Now, I can copy anywhere on the external device, not just the data or media folder. So, my query has been solved.

I would like to thank you and @Catfriend1, much appreciated for your input.

This guide is for future users seeking a solution to set up Syncthing with an External USB Drive on their Google/Android TV. If you encounter the error message

“Your Android version does not allow syncing to external storage devices”

follow these steps:

Before You Begin:

  • Using a wireless keyboard and mouse is optional but recommended for a more convenient setup.
  1. Install Syncthing on Google/Android TV:
  • After installation, set up your device.
  1. Adding a Folder from External USB Drive:
  • Open the Syncthing Android TV App and click “Add Folder.”

  • Select the directory using the first option and give it a name of your choice. (Please refer to the Screenshot) 64bc0e12726f0fc1ebec0266ce2495d6d22fe2ed_2_690x388

  • Press OK. (Ignore any warnings like “it’s empty” and proceed.)

  1. Accessing the Folder Path:
  • Click the left side menu and go to WEB GUI.
  • Select the folder created in Step 2, click “EDIT,” and note/copy the exact path.
  • The path typically looks like

“/storage/7663-1501/android/data/com.nutomic.syncthingandroid/files.”

  • Only the part before “android” is needed (e.g., “/storage/7663-1501”).
  1. Setting Up External USB Drive on Syncthing:
  • Go back to the WEB GUI and click “Add Folder.”
  • In the path, enter “/storage/7663-1501” followed by the desired folder name for synchronization (e.g., “/storage/7663-1501/TVSync”).
  • Once the folder is created, a notification will appear on your PC’s Syncthing.
  1. Completing Setup on PC:
  • Set up Syncthing on your PC as usual.
  • Your external USB drive on the TV is now configured for Syncthing.

By following these steps, you can successfully sync data between your PC and Android TV using Syncthing with an External USB Drive.

2 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.