Syncing 110%

All of my systems are in sync but on one of them it’s showing under “Remote Devices” that my main system is still syncing and it’s at 110% Everything seems fine and it’s on only showing this on one device but I’m not sure how to fix it.

What Syncthing versions are involved?

Sorry should have specified that - v1.6.0-rc.5, Windows (64 bit)

both sides?

No the other side is showing everything is synced up. Since my first post I have added more files and now it shows 100% but still syncing.

Sorry, I was wondering what version you are using on the other side.

Ahh sorry - it’s the same (v1.6.0-rc.5, Windows (64 bit)) All my systems are using this version.

I removed the folder and files it was showing not syncing properly to see if that would fix it. It now shows “Up to Date” on my laptop (this is where it was showing the syncing 110% issue before) - but I started getting these errors on DL-Data-01 - “directory has been deleted on a remote device but is not empty; the contents are probably ignored on that remote device, but not locally”

I also noticed on DL-Data-01 that it is showing for Global and Local State 0 files and 4 folders and 4.19 GiB. There should be 3 files - clicking the rescan doesn’t fix it. Actually looking at the other systems that are syncing this folder - the Global state is all over the place. Only one system DL-Data-02 is showing the correct information.


DL-Data-02: (Correct)



I realize I could probably just remove the folder and add it back in again on - but I just wanted to see if there was a way to fix this without doing that. If the folder had a lot of data - starting over would be a pain.

There’s a few measures short of removing the folder that might resolve the problem. However even if successful that’s not wholly satisfying for me, I don’t want to know how it happened (well actually I don’t want it to happen, but…). So first a few infos you could provide to start debugging, then those steps :wink:

What’s the info on the two failed items?
Does running stindex -mode idxck /path/to/your/index-v0.14.0.db result in anything on any device (tool can be obtained from - guest “login” possible).

To try and resolve it, you could run syncthing once with the env var STRECHECKDBEVERY=1s set.

The 2 filed items are - “directory has been deleted on a remote device but is not empty; the contents are probably ignored on that remote device, but not locally”

I’m not sure what the tool does but it worked. All the systems I ran it on fixed that folder and it’s now showing the correct information.

Thank you.

What’s “the tool”? stindex should have printed information on the command line, but not changed anything. STRECHECKDBEVERY=1s checks and fixes known possible inconsistencies in the db.

Well then I’m not sure what happened. My only guess is restarting Syncthing fixed the issue (I thought I already hit the Actions --> Restart but maybe I didn’t. I had to shutdown Syncthing to run stindex.

Thanks for your help.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.