Sync Network Drive (WIN7) - Howto


I am trying to setup Syncthing on a WIN7 machine with LAN mounted directories. The response I am receiving the following error 10:47:57: Stopping folder “Work-S” - mkdir s:: The system cannot find the path specified.

I tried defing the folder as “s:” or “s:/” with same results. Any idea?

Thanking you in advance

Does s:\ in fact exist?

of course. :- )

It’s there for a few years, (had no problem with another sync software (BTSync) Thanks for your response/ MS

Can you provide your config? (with the sensitive bits removed) Also, try capital S


I tried capital S with no success.

Here is the file:

<configuration version="10">
    <folder id="default" path="C:\Users\WIN7\Sync" ro="false" rescanIntervalS="60" ignorePerms="false" autoNormalize="false">
        <device id="{REMOVED}"></device>
    <folder id="s-work" path="S:\" ro="false" rescanIntervalS="60" ignorePerms="false" autoNormalize="true">
        <device id="{REMOVED}"></device>
        <versioning type="simple">
            <param key="keep" val="10"></param>
    <device id="{REMOVED}" name="MOSHE-WORK" compression="metadata" introducer="false">
    <gui enabled="true" tls="false">


I tried again with full path rather than the drive letter, and got this as a result:

11:59:21: Stopping folder “S-Work” - open \RECEPTION\Office Documents\Moshe.stfolder: Access is denied.

11:59:24: Loading .stignore: open \RECEPTION\Office Documents\Moshe.stignore: Access is denied.

Full path being \\<machie name>\<path to folder>\? I think you need double \\ in the front. Also make sure you have read/write permission.

Thanks, but

I put double “\” in fromt. It shows here only one.

Permissions are RW for Everyone

Are you using NSSM or something like that to run syncthing as a service?

YES According to recomendations here:

NSSM runs stuff under a different user (service user AFAIK) which probably doesn’t have access to the network share.

Syncthing is logged a local system In any event, the remore directory has RW permissions to EVERYONE.

Try running syncthing directly and see if that works.

It seems OK. Should I define the RW permissions for the user AFAIK on the folder?

Bypass: I created a new local user and used it to run the Syncthing service on local machine. I still had to provide full path rather than the drive letter.

All- Thanks for your help

Please make sure you’re aware of the security implications of running Syncthing as a service/privileged user, and make sure you secure the GUI. I’ve updated that wiki article.

See posts such as: