Sync is aborted, log says "switching connections"

Hi guys

A friend and I have a problem with a newer folder we’re sync trouth syncthing. In the log it shows at me: Connection closed by remote computer And at him: Switching connections. What does this mean? I didn’t find something about that switching connections.


Instead of using a relay, it switches to a direct connection.

What does that mean exactly? We have nothing changed, only added a new folder. It worked before… What is the problem? What do we have to change to get it work again?

Thank you very much!

Here is the log: [3RT2I] 01:15:54 INFO: Connection from (direct-dial) with ignored device ID TLQZPZR-RHTKZBS-QZNDFI5-xxxx

[3RT2I] 01:16:26 INFO: Established secure connection to VRY6ORX-RO4MOOL-xxxx at (relay-accept) [3RT2I] 01:16:26 INFO: Device VRY6ORX-RO4MOOL-HB3RRIP-Y7GYHCF-xxxx client is “syncthing v0.12.17” named “SERVER”

[3RT2I] 01:17:22 INFO: Connection to VRY6ORX-RO4MOOL-HB3RRIP-Y7GYHCF-xxxx closed: switching connections [3RT2I] 01:17:22 INFO: Connection from (direct-dial) with ignored device ID TLQZPZR-RHTKZBS-QZNDFI5-KEUMNS7-xxxxx

[3RT2I] 01:17:22 INFO: Connection to VRY6ORX-RO4MOOL-HB3RRIP-xxxx closed: write tcp> use of closed network connection

[3RT2I] 01:18:23 INFO: Connection from 46.127.xx.xx:22000 (direct-dial) with ignored device ID TLQZPZR-RHTKZBS-QZNDFI5-xxxx

Well we haven’t changed anything either. It seems that you were connecting via a relay before, and one of you either enabled UPnP, or tried to set up port forwarding which is not fully functional and now causing this.

Ah wait, I did enable UPnP some weeks ago (Don’t know that this effects syncthing too). I’ll check this. So we both have to enable UPnP or both have to disable it? Thank you very much, now I have an idea where the problem can come from.

It was UPnP. After I unchecked it, it worked again. Thank you so much!

So if upnp would work properly, it would actually be beneficial to you, as now you are probably connecting via a relay, and have limited bandwidth.

There’s nothing in that log which indicates Syncthing is attempting or failing to establish a direct connection with VRY6ORX.

What could UPnP be doing to allow enough of a connection for Syncthing to drop the relay connection, but not enough to actually allow it to communicate?

Well, local firewall I’d say. Or are you suggesting I am not perfect and I make mistakes in the perfect code I write? :smiley:


Wait, you aren’t perfect?? I have to change the tool :stuck_out_tongue:

Just kidding. Can I see somewhere whats in use? Direct or over a relay. In the log is “(relay-accept)”. So the connection is over the relay. Can I see this info on the gui?

Where can I read about what I need to get a direct connection? Just both have to enable UPnP? (And open port 22000?) (Firewall…^^)


So in the web ui, when you connect to a device it shows the ip address of the device.

If it says Address it’s direct.

If it says Relayed via, you’ve guessed it, it’s relayed.

The switching code hasn’t been thourly tested, so it’s possible it has bugs. Yet I’d expect more people complaining if it was.

Docs about the firewall and whats required can mostly be found in the, but essentially working upnp on either side should be sufficient.

Unless there’s a firewall getting in the way, as it looks like there is here?

Yes, thats what it looks like to me.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.