Sync drops to 0B/s, never syncs, disconnects randomly

I had syncthing working before, but I reinstalled my server and now I can’t get it to sync!

When my server connects to my laptop, it briefly uploads at about 22kb/s, then it almost immediately drops to 0b/s and stays there.

The error log (on the server) shows many messages that say “Puller: final: peers who had this file went away, or the file has changed while syncing. will retry later.” The last message in the log says it connected with my laptop again.

I disabled relaying in case that was causing the slow transfer rate. The behavior is identical still.

In addition to this problem, the server and laptop seem to have trouble staying connected—they shift from connected to disconnected, and I have to restart syncthing to get them to connect again.

A third problem: I tried deleting the server copy of one the folders, and then syncthing complained that it wouldnt sync because the folder was missing. So, I removed the folder from the server and added it again by resharing it from the client. Now it happily says it is synced on the server, even though it isn’t at all.

It was working well before I reinstalled my server, so it shouldn’t be port forwarding or anything like that, but I don’t know, maybe it is.

Can anyone help? It was cool when it worked, now it is just frustrating >_<;;

1 Like

The logs will have the reason for disconnection. The folder being up to date is probably because it’s not shared with anything.

The folder which is wrongly up-to-date is definitely shared with the client, and seems to have been linked correctly.

I found the reason for the disconnect in the logs: “closed: read timeout”, similar to this unresolved thread.

Why would there be almost constant read timeouts? I just disabled QoS on my router and restarted both syncthings, in case that was causing dropped packets: no effect.

1 Like

FWIW, the issue on the other thread came from the connection dropping when on low quality links. I was not able to trace it back to which device was actually dropping the connection:

  • Was it the router expiring the connection too fast?
  • Was it syncthing giving up on the connection too quickly?
  • Was it my OS’s network stack?

Whatever it was, it seems it was dropping the connection much faster than the standard 2 minutes mandated by the RFC (in 2 minutes, the re-transmits would have caught up). But breaking that aspect of the RFC is very, very common in many network devices and software.

I tried syncthing on a better connection and the same thing happens. It seems unlikely that it’s the network, since the only thing that changed between before (when it worked) and now is that I reinstalled Syncthing on my VPS. Maybe it’s something in the server’s setup?

Does anyone have any ideas, or ways I can troubleshoot this? Still the same problem.

1 Like

Did anyone come right with this issue? As I am now suddenly experiencing it


I think i have the same problem. When i start to sync between my ubuntu and my android phone Syncthing begin to sync and five second later the Sync drops to 0B/s.

The sync restart when i restart Syncthing and the sync drops again to 0B/s It’s a big problem because it will take many time to sync a few files.

Sorry for my english i’m french.

1 Like


YES !! Thanks for the information ! i install it and the problem seems to be fixed… I’ll continue to testing ! but it’s great for the moment !!

This doesn’t fix my issue :-(. I upgraded both computers to the v0.14.18, restarted both syncthings, and the behavior is the same.

1 Like

did you restart syncthing on your two computers ?

between my android and my pc ubuntu it worked

Yes, and I even checked the About page in each one to make sure the version had updated and was running.

If you’re still suffering from closed: read timeout then that is indeed something else, not related to this. Since not many people seem to be seeing that I suspect your network, somehow.

Hi everybody! Wishing you guys a happy new year and I have to say, Syncthing really is an awesome software! But I have a similar problems like mentioned above:

I had it running on my raspberry pi on my local network with an older version of syncthing for quite a while without any issues. Now that I have it connected at my parents place running 0.14.18 on all devices I experience the sync drop to 0 B/s after a short period of syncing (30 - 60 secs) at normal speed. Screenshots attached.

Any help appreciated! Best wishes michael

1 Like

I have confirmed that this glitch is happening on other wifi connections as well. So it’s probably either something with syncthing or with my linux setup, which is Windows Subsystem for Linux.

I’m trying to do my backup so I can switch to a full linux distro. Hopefully syncthing works on WSL and I don’t see why it wouldn’t.

I’d really appreciate any help on this problem! Already reinstalled both ends of syncthing and upgraded versions twice. In a few days I will probably look for another solution but I wish syncthing worked because it’s perfect!

1 Like

Found a workaround: I installed the Windows version of syncthing and it seems like the drop to 0B/s issue is not recurring! I didn’t realize syncthing was cross-platform or I would have tried that earlier.

This fix might work for others who are using Windows Subsystem for Linux, but it doesn’t solve the problem for others who reported in this thread.

Oh, you were running the Linux version of Syncthing under the Ubuntu-for-Windows thing? You might be the first person to ever try that :slight_smile:

I have the same issue. Five devices, all in the same subnet, three of them connected via cable, 0kbp/s sync speed. Our LAN serves a solid GBit connection, but syncthing is stuck. This is not overly dramatic to me, but a fix would be cool. Do you need additional information?

0 bps sync speed just means it’s not syncing. Look at the receiving side for errors. If there are no errors, perhaps it’s just happily in sync? It’s impossible to tell from the screenshot.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.