Sync Conflict Files Created Despite Having Same Hash


As always, many thanks for an amazing tool - it works so well for me, and with so few problems!

I’m having an issue with some sync conflicts being created - even though the original and conflict file generate the same md5 hash. I think I know why this might be happening - but I stand to be corrected:

  • The files are ‘large’ and reasonably old. I suspect they were indexed by some machines in the sync cluster before the block size was changed for large files;
  • A new machine is then added to the sync cluster, with a shared folder which has been pre-seeded with necessary files (due to the size of the folder making it impractical to wait for Syncthing to populate it);
  • This new machine then indexes the files with the new, larger block size - creating files which are seemingly in conflict with those already indexed by other machines.

Is there a good case for a periodic conflict cleaner which:

  • Scans the filesystem for conflict files and their original counterparts;
  • Performs a complete-file hash to determine a non-required conflict;
  • Remove the conflict file;
  • Update the cluster’s records with the appropriate blocks for the original file.

I know - it’s easy for me to write and suggest… :wink:


Your assumption about what’s happening sounds reasonable, back when large blocks were made mandatory this came up a few times.

I personally solved this issue long ago by nuking my old databases, to ensure all block hashes were in the newer format/size. Don’t know if that’s an option for you, but it worked for me.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.