.stignore

Hi everyone,

Syncthing is refusing to load the folders in my system, and the following error message is coming up:

Loading ignores: lstat /media/sacpop/My Passport/Syncthing/John/.stignore: permission denied

Error on folder “John” (feisk-rsyse): stat /media/sacpop/My Passport/Syncthing/John: permission denied

How do I fix this? I’m not sure what has broken, as it used to work perfectly with no issues.

Syncthing doesn’t have permissions to read the file.

I’m not sure what has happened to take the permissions away, but how do I give it the permissions back?

It depends on your operating system, how you manage your operating system permissions is not really a syncthing question.

I’m currently running Linux Mint, and I appreciate your patience; I’m not an experienced Linux user yet, and given that Syncthing previously ran without a hitch post-setup, I’m a bit lost on this. Is there a way to give it permissions through the GUI? Otherwise, what’s the name of the Syncthing user?

No, you can’t make an application give itself permissioms via the ui, given it doesn’t have them.

I can’t tell you what user syncthing is running as, as it all depends on how you installed it.

Again, things like “check what user application is running as” can easily be googled as I am sure there are prior art for these sort of questions.

I’ve checked and the user syncthing is running as has full read/write/execute permissions across all the folders and subfolders, but the error persists. Any other leads on what it could be?

It also needs permissions on the parent folder etc.

Sorry, but no new leads, we’re just giving you the error message we got from the operating system. Why the operating system doesn’t like it, we can’t tell you.

You might want to change the ownership of directories you are syncing to be owned by syncthing.

The path looks like some kind of external disk so mount options, file system types and ACLs may also be in play. :man_shrugging:

In such distributions Syncthing needs full permission read/write in the related folders. In the Cinnamon filemanager you can setup the permissions in the right click menus.

To setup the permissions I use the Dolphin filemanager, its easier to setup permissions. For Syncthing I create a user “syncthing” to have a possibility, to give this user permissions. This runs.

I couldn’t figure out what it was. In the end, I deleted the connection, then when the other computer reached out, I established a connection with a new folder and it works. Very strange.