[SOLVED] Second syncthing not starting?

I am trying to install syncthing 64 bit version on a Windows 7 machine. I have already installed the service and am able to control it from command line. I am not able to connect on, UNLESS I start syncthing by double-clicking it (which spawns a DOS console).

In the runnning processes, I see two syncthing instances when this console is open, and only one when it is not. When the second instance is not present, the connection is refused to syncthing.

What am I doing wrong? Why is the second syncthing process not starting automatically? TIA

[SOLVED] All I had to do was start the service for syncthing as a regular user and NOT USE THE LOCAL SYSTEM builtin account. Thanks canton7.

I should also add that it is running beautifully on a freenas box as a plugin. So, I am pretty familiar with the setup and firewall settings, folder settings etc. I have also shut off UAC. Same thing happens whether the firewall is on or off.


I know you got this solved, but just FYI, you cannot have two processes listening on the same port, so if one is listening on 8384, you will have to configure the other to listen on a different port, such as 8385.

dave – Sorry if it wasn’t clear, but I was referring to the instance of syncthing that is spawned by the ?daemon, also called syncthing, that runs when you start the program.

From the FAQ:

Why do I see Syncthing twice in task manager?

One process manages the other, to capture logs and manage restarts. This makes it easier to handle upgrades from within Syncthing itself, and also ensures that we get a nice log file to help us narrow down the cause for crashes and other bugs.

Oh, so now even I understand what you’re talking about. :slight_smile: Most likely you had a permissions problem or similar when running as the other user, so Syncthing couldn’t start or open it’s database. Hence the “second” process exits and the first tries to restart it a couple of times.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.