[Solved] Mac binary 0.14.15 not signed?


It’s been two days I’m getting MacOS firewall asking me if I want to accept incoming connections, anytime I’m connecting to the network.

Syncthing is marked as accepting incoming connections, as it has been since I started using it.

It appears this popup started after upgrade to 0.14.15.

I came across this topic (OSX) Do you want the application "syncthing" to accept incoming network connections?

I checked the signature with codesign and apparently the latest version is somewhat considered not trusted.

macbook:syncthing sw$ ./syncthing --version syncthing v0.14.15 “Dysprosium Dragonfly” (go1.8beta2 darwin-amd64) jenkins@build.syncthing.net 2016-12-17 11:39:22 UTC macbook:syncthing sw$ ./syncthing.old --version syncthing v0.14.14 “Dysprosium Dragonfly” (go1.7.4 darwin-amd64) jenkins@build.syncthing.net 2016-12-13 10:29:40 UTC

macbook:syncthing sw$ codesign --verify -vv syncthing syncthing: CSSMERR_TP_NOT_TRUSTED In architecture: x86_64 macbook:syncthing sw$ codesign --verify -vv syncthing.old syncthing.old: valid on disk syncthing.old: satisfies its Designated Requirement

Thanks in advance, Seb

Hi, I’m getting this as well every time I bring my Macbook out of hibernation. I seem to remember a similar issue a year or so back when an earlier release wasn’t signed properly. Ron

I updated the certificate but apparently screwed up. It’ll be rectified in the next release, sorry about that.

I’ve re-uploaded correctly signed binaries so if you download those manually from GitHub, or downgrade to 0.14.14 and let it upgrade again, you should be back on track with a signed binary.

Thanks. I confirm the new binary is signed now.

I’m still having the firewall issue though. I made sure to remove syncthing from the accepted applications in the firewall settings, but I’m still getting the popup.

@ronmc can you check and see if you still get the issue on your side?


It’s working for me, thanks. I downgraded to 0.14.14 by renaming the syncthing.old in the runtime folder and restarting. Then the auto upgrade kicked in and picked up the new version. Ron

No firewall issue anymore?

That’s correct - the firewall messages don’t appear anymore. And it’s syncing OK. Ron

Thanks @ronmc.

Works for me now. I was replacing the old unsigned binary with the signed binary manually but apparently the OS didn’t pick up the change. After downgrading and letting Syncthing update itself all is fine.

Thanks guys!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.