Slow loading of GUI

I’m using Syncthing on my two home servers for a couple of days now. Unfortunately I have a problem loading the GUI on one of my servers. Strangely it’s the fastest server :smile: . The problem is that loading the GUI takes about two minutes or so; eventually it shows up. As said before, this only occurs on ONE of my servers. I don’t know why it’s slow, the hardware resources are almost zero at the moment I do the GUI-request. Therefore I don’t know how to debug this problem…

Any help highly appreciated!

It has a short initial delay while syncthing is starting up due to lock contention, but it should go away once it’s more or less idle. @calmh we seem to be having quite a few issues caused by the UI routine… How can we nail down the issue?

Thanks for your reply, however it’s not the initial (first time) loading of the GUI after starting the daemon. It’s always slow, also when the daemon has been running for a couple of hours.

Do all requests take long, or only the first one?

Almost all request. Most of the times I try to open the GUI, the page stays “empty” for about two minutes. After these two minutes, the GUI appears. But sometimes my client (Safari) is receiving some html, but the connection with the backend is not there. See this screenshot. After a while (approx. 30 seconds) the data is retrieved from the backend/server and the page is correct.

This is very strange, as it seems the static assets are failing. Although these are not contended by any locks. Once the page loads, can you open the web inspector and see if the AJAX requests are responding fine?

Hmz, I did some investigation myself. It looks like the tunnel I used for reaching the GUI wasn’t working fine. I now have set the GUI to listen on, instead of localhost only and tunnel 8080:localhost:8080 for opening GUI. It seems to work fine now… I will try some more. Will let you know.

[by the way] I used to use Bittorreny sync… but i’m VERY happy I’ve discovered Syncthing. yeah!

Hey I’ve recognised, that each time I open the UI it starts from scratch initialising alle Files in an folder. Is that correct? With a folder of 20k files it needs quite a while :wink: I’ve observed also, that this initialising process needs quite a bit of ressources and because of that the syncrate between two machines decrease drastically. Mabye the case of this behavior is something else, but it seems to me that it is like this.

So hear some measurements: The rate during normal sync is about 150kB/sec. After I opened the UI, it was for more than two hours around nothing. The first decrease in the diagram was after I opened the UI:

What does the version string print? What sort of device is it running on? I assume you can easily reproduce this?

I don’t think it starts scanning when you open the UI, but it does do more database work which probably slows it down.

OK, its not a super-ultra-server :slight_smile: => Qnap TS-421

I saw, that the CPU-load was around 50% for Syncthing.

Yes, it was now allway like this. Maby because it is still not finish with initiallising the files and when I open the UI I force Syncthing to initialise further?

{“arch”:“arm”,“longVersion”:“syncthing v0.10.18 (go1.4 linux-arm default) unknown-user@syncthing-builder 2015-01-06 22:12:40 UTC”,“os”:“linux”,“version”:“v0.10.18”}

Yeah, wait for it to finish indexing (if it says scanning, then it’s not yet finished), and see if the transfer rates slow down when UI is open when you are not transferring anything.

Ok, then I waite :smile:

One of the folder shows me 59300 entries, ~147 GiB, Scaning An other 500 entries, ~76.5 GiB, Scanning and the third: 117900 Einträge, ~149 GiB

Maybe the directories are a little bit too large, or what do you think?

Don’t think so, I saw people with 500GB and it seemed to work. Obviously it all depends on the type of device you are running syncthing on. Raspberry PI might struggle to index 100GB.

So, new observations: Now it has everything initialised and it should start to sync. But it gives me every time, when it tries to sync the folowing failers:

So the to machines sync something for severeal seconds, and after it is again for a long time nothing:

And after that it shows me that the connection to the other machine is terminated. What could be the problem?

So as an update: Yesterday, it synced nothing, despite the fact, that the two machines are 500GB in difference to sync. And I’ve tried not to open the UI, so not to desturbe Syncthing Today I tray the other way, I opened Syncthing once, so I hope it will kick on Syncthing to do something. I will see…

I saw now, that Syncthing changed the folderpermission on the original folder to admin. So no other groups or Users has now access to it :frowning: It seems, Syncthing is all the time with no other engaged than with changing folder-permissions. Grrr

This is a bug which has been fixed in a recent version, see:

Which version are you running?

I use the last version 18

Are all nodes on 18?

You can either try running this special build on all machines: (hasn’t finished building yet) (you only need to start it, and should see message: “Dropping invalid nil filename from database”, after that you can go back to version 18)

Or if you don’t want to run a special build, need to shut down all your nodes, delete the index directory in syncthing’s home dir on all machines, and start it again. You have to do this simultaneously, not one by one.

There was a special build which fixed the issue, but