Runcondition for specific WLAN not working anymore on Android 10


I write here because the issue sction is not available at github.

I use the app for quite some time with specific run condition, those doesn’t work after upgrade to LOS 17.1 android 10 and have worked fine under Android pie LOS 16.

The app doesn’t start if I arrive my home wlan network. I have tried to reconfigure, but I’m unable to choose a wlan. The button doesn’t act with me. I have read, that for wlan the gps location is needed and it is granted to the app, but according to the logs, never used or asked by the app.

Any suggestions to solve this?

Danke /Thanks Micha

The screenshot means, please enable wlan to choose one, but as you can see at the top, wlan is running.

Please write in English, even if the maintainer @Catfriend1 speaks German, to make the information accessible and potential relevant to a bigger audience - dankeschön.


Android 10 has limited the access for SSIDs the system already knows. That’s the cause why you can’t select from known networks.

I’ve put a dirty fix in Syncthing Fork a while ago as I didn’t found a way to make the original wifi ssid enumeration work again conforming with gplay policies. The fix mainly consists of auto learning when a known network is connected while the app is foregrounded. Not very intuitive, but better than nothing. Maybe some Android coder has a better idea based on mine to fix this properly.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.