Repeated Failure: no connected device has the required version of this file

I added a new folder to a new device, and now Syncthing is constantly “spinning” on all of my devices stating that the folder is out of sync due to a single file and constantly (multiple times per second) rescanning. The folder on the new device has a file “.syncthing.FILENAME.pdf.tmp” instead of the actual file FILENAME.pdf. All other devices have the correct file.

I have tried the following:

  1. Deleting the file in all devices --> Result: still rescanning.
  2. “Touching” the file on a device --> Result: still rescanning.
  3. Turn off Syncthing on new device --> Result: rescan stops (but obviously new device doesn’t work).

I’ve read all the other threads with this same topic, but see no solutions. Thanks.

UPDATE: This did not work. So it is still not working.

The error is a “no such file” error (I can’t edit the original post).

I “fixed” it by completely uninstalling Syncthing on the new device and reinstalling.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.