Renaming of folder types

I might tackle 2679. What do you guys think the folder types should be named, to make it a more clear to users?

My favorites are: Push / Pull Pull Only Push Only

A variation of this could be: Send & Receive Send Only Receive Only


I suggest Default Send Only Receive Only

1 Like

I think the send / receive division is about as clear as anything I’ve come across.

1 Like

Agree, these are the most understandable.

Awesome, those are my favorites also.

What should I name everything internally? Example: SndRcvFolder, RcvOnlyFolder, SndOnlyFolder SRFolder, ROFolder, SOFolder SendReceiveFolder, ReceiveOnlyFolder, SendOnlyFolder

This would be my preference. I’d hold off on changing anything externally visible though (i.e., config keys). And this change should be separate from the new receive only folder type, preferably preceding it.

Actually I think we should keep internal naming as it is, as you have to be go into thr code to be affected by that, which means you can probably work out whats what.

I don’t immediately mind either way. If the diff is huge and hairy and for no purpose then I fully agree with Audrius. If it’s small and aligns the internals with the outside that’s OK too.

The internal stuff would need config migrations, so I’d stay away from it.

If I sum up the discussion above, then you’re telling me not make any internal or external changes. :facepalm: You guys are killing me!

I was planning to change everything. It did not seem like a huge amount of effort or a lot of code changes. Mostly a search and replace exercise. The documentation is probably the biggest pain (and what I suck at the most).

In regards to the config change, the migration to the new config name would happen automatically. Are you concerned about this piece? I haven’t looked very closely at that piece of the code yet, but it seems you guys already have the framework for this.

I agree that it makes sense to rename the folder types first, then send in the receiveonly changes.

Well you can probably do the whole lot of you get the handle on config migrations.

No, I’m saying don’t change external things that are part our API, such as the config, or things like synctrayzor and android will fail. Changing it would essentially require a 0.15 release.

I thought Audrius was saying don’t rename everything everywhere internally if it’s just a massive confusing change with little benefit. I could go either way on this.

I’m still saying rename it where it matters - the GUI and documentation. We might want to accept “send-only” as a synonym for “readonly” in the config or so.

1 Like

Ah yes, API compatibility, I keep forgetting that.

1 Like

Makes sense. I’ll try to keep all of that in mind, when I start hacking away.

1 Like

I submitted the first version of this change via a pull request. Right now it’s internal changes only. I haven’t yet figured out how the API works (any pointers possibly?), so I have stayed away from renaming configs.