Remote shows Sync, Local shows Syncing 99%

Hello. I’m new to this forum. Searched for a solution but did not find it.

These are two windows PCs. My issue is that the local Syncthing claims OutOfSync ( and is true ), but the remote claims “Up to date”. So I clicked the “Out of Sync Items” and copied the missing files to the remote ( …actually wrote a script to pull the data, but is effectively the same ).

Now, how can I tell Syncthing to push the files out of sync “forcefully” to not do it manually and/or tell the local db that is all fine ?

The watcher has been sending the new files just fine. This is from the initial sync of about 400,000 files, were these 750 files are known by the local db to be missing, and by the remote db to be, fine I’d guess, as it shows the same file count.

cURL examples are most welcome as my script is all HTTP but if command line is required, then that’s ok too :smile:


PS: in the FAQ, where it say “special characters such as [ and ? are not allowed in file names on Windows” is wrong, as [ is valid in a filename on Windows. I’m new and dare not edit it on github ( nor have an account ).

…forgot to say that the local is SendOnly and the remote is ReceiveOnly.

Local send-only being out of sync means the remote side updated some file, hence your local instance is now behind, and given it’s send only, it refuses to accept changes made by the remote device.

You should see an override button, which will nuke any changes the remote side has done (potentially causing data loss).

If this does not answer the question, please post screenshots from both sides.

…I don’t find an override button :slightly_frowning_face: Is there an override URL ( GET or POST ) ?

“Revert Local Changes” is the override button.

…interestingly, the local side was right. Those 750 files were not at the remote PC. And the remote PC claimed to be up to date.

Now, I click on the “Revert Local Changes” and it removed the missing files I copied over. So I copied them back.

So I now have two problems:

  1. tell the local that is all good
  2. tell the remote that is all good

…or a way to synchronize it the Syncthing way. …or a way to edit the database

I’m so new at this, I have no clue on how to approach my problem :frowning_face:

If it still does not line up, post new screenshots.

The remote looks good now. It accepted the files. The local did not change it’s sync. status.

Edit: …would you know how/why the remote got to acknowledge the manual copy as good ? :confused:

Also, the forum will not let me add to a post due to my newness, 16 is the limit for me today :smiley:

Are the 750 files all in the folder you expanded? As per out of sync dialog.

yes, all 750 files are replicated but the local claims “Out of Sync Items” to be those 750.

That’s not my question, my question is whether all the files listed belong to the same folder, and that is the folder that is expanded in the screenshots.

yes, that is the folder (and sub-folders), and it is the expanded one.

Ok, looks like a bug.

@calmh @imsodin ideas?

Yeah. Maybe some sort of database badness (1.4.1-rc looks for and fixes some that could be relevant?), but also I’m not fond of the send-only-to-recv-only combo at the moment. I feel there are corner cases there in how updates are handled, but then again this looks rather straightforward (no “override” + “revert” involved)

I guess, try upgrading to the latest release candidate and see if it goes away.

rc.3 will be final in a few days, so I rather use the final version, given that these are production PC, although 1.4.0 went to rc.11 before becoming final.
Will this release be extended farther ?
If it will not be final, then rc.3 will have to do for now.

Let me know if it will release on the 6th ( as I remember reading somewhere I can’t find right now ).

Edit: …found the reference " The current release candidate is v1.4.1-rc.3. The next release, v1.4.1, is expected 2020-04-07"

That’s still the plan.

1 Like

Update: It solved by it self upon update.

I would change the title of the post to solved but I don’t know how