Relay: unknown response type from server 401

I have 2 IPS on one interface, the primary being eth0 and the second is an alias at eth0:0. I wish to use my spare IP to run a 443 relay.

eth0 inet addr:64.137.233.135 Bcast:64.137.233.255 Mask:255.255.255.0 eth0:0 inet addr:64.137.233.248 Bcast:64.137.233.255 Mask:255.255.255.0

I want to run the server via the alias by telling syncthing to listen on 64.137…233.248

/usr/bin/strelaysrv -keys /etc/relaysrv -ext-address=64.137.233.248:443 -status-srv=64.137.233.248:22070 -listen=64.137.233.248:22067

however I get this response

https://relays.syncthing.net/endpoint unknown response type from server 401

when I run netstat syncthing is listening on the correct IP tcp 0 0 64.137.233.248:22070 0.0.0.0:* LISTEN tcp 0 0 64.137.233.248:22067 0.0.0.0:* LISTEN

I treid removing the ext-address but this also gives the same error /usr/bin/strelaysrv -keys /etc/relaysrv -status-srv=64.137.233.248:22070 -listen=64.137.233.248:22067

My guess it is to do with the fact that the traffic is 64.137.233.135 but it says the relay is announcing its on 64.137.233.248.

I guess I could run it on the primary interface for now, and use the secondary one for https.

Correct. You are not allowed to announce for someone else.

The Listen parameter on the relay server should ideally take care of this, but it currently doesn’t. I think this is a legitimate feature request on strelaysrv.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.