Relay-less Syncthing completely broken

I’m slightly annoyed about this; before relaying, I had set up NAT forwarding for the ports required for my instances and everything was well. I tested UPnP; that worked as well, but for security reasons I decided to stick with manual port forwarding/opening.

Ever since relaying was introduced:

  1. Connections via relays take a long time to be established and are very fragile; my nodes disconnect frequently (obvious pitfalls of a free and donation-funded architecture that I can absolutely live with, given other options)
  2. If I disable relaying and UPnP (ports are still forwarded), nothing connects, ever. My nodes just sit there doing nothing (tested for > 24 hours)
  3. Enabling UPnP doesn’t work, either; it creates UPnP rules that forward to port 0.
  4. Local discovery (two physical computers connected to the same physical switch on the same subnet) doesn’t work anymore, either.

It seems that anything but relaying is completely broken. The advantages of an open (and free!) relay infrastructure are obvious to me and I welcome them, but to totally shut down any other choice in the matter seems a little harsh.

Something else is broken for you. I run all my devices without relaying and it works as well as ever. In fact, relaying is always intended as a last resort fallback that is hopefully “never” used.

The obvious, usual candidates are firewalls and antivirus packages.

Or post some configs, logs and/or screenshots and we’ll take a look.

After some digging around it turns out that the listenAddress parameter now needs to have “tcp://” specified in front of the address. So I was somewhat… rash. However, I remember that “0.0.0.0:22000” was a valid address, apparently this was changed at some time?

Anyway, thanks for the quick reply. Interesting that relay would still work even though the listenAddress was apparently incorrect.

I’m slightly surprised it starts up at all without a valid listen address. It possibly shouldn’t.

The listen address format should have been auto migrated when you upgraded, though…

Did you ever use a version build from git? I had the same problem when testing development builds, which did not include the config-automigrate feature for that particular version yet.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.