Raspberry Pi Stuck in Pause


I installed Syncthing on a raspberry pi 3B+ debian 10.9 buster. Setup was very easy and smooth. I only have one folder shared with a Windows 10 PC. Both systems are hard wired and on same LAN. Everything was working great then with no changes it stopped working. I tried everything I can think of and everything I an find online to get it working. I noticed that in the raspberry pi browser tab the syncthings logo has a pause image overlayed, and for the windows 10 tab it does not. It seems that the raspberry pi is stuck in pause. I made sure it wasn’t paused in the menu and in the config file.

At this point the only thing that I hadn’t tried was to uninstalled syncthing from both the pi and windows, deleting all files related to syncthing just to start fresh, that includes the config files. Reinstalled and set back up and windows seems to be working fine, but the pi still has the pause icon in the tab. After this I turned to my router unifi (dream machine) even though I didn’t change anything between when it was working and now. I tried turning UPNP on, but that didn’t do anything. I made sure I wasn’t blocking any ports.

Thank you in advance for any help. Capture

This may not be directly related to the issue, but make sure that you are running the newest version of Syncthing on the Debian machine, and not the very old one that they ship by default.

It should be the newest version, but I will double check. Thank you for the suggestion!

The browser tab icon/favicon is a bad indicator, it often doesn’t have much indication to whatever is happening right now.

I don’t understand what the problem is though: Can you access Syncthing’s web UI from the Pi? If no, check logs. If yes, what is the status/problem there (screenshots)?

I’m running a headless setup, so is there a way to check if the web UI is accessible with my setup?

Logs: It prints the address it is listening on. Or Config: Should have the gui listen address set to

Yep, I have it set to so I can access from my desktop. When I go to the log it shows that the PI is connected to a relay, but when I add my PI device ID to my windows PC the PI is never notified that it’s been added.

That’s a completely different thing. A relay is about device connections, before I thought we were talking about how to access the web UI. Can you please specify what your problem is. E.g. can you access the web UI on the PI or not?

Oh no, I have always been able to access the UI from my desktop pc. I’m running a headless PI so I’m not able to check on the PI itself if I can access the UI. I would assume since I can access it from my PC then I would have access on the PI directly as well. The problem is the PI won’t connect to any other devices, nor will it be notified when I add it’s ID into another device to share a folder. That’s why I mentioned the pause symbol in the browser tab for the PI UI, but it’s not there in the browser tab for the windows UI. I know it was mentioned that is not reliable, but that was just a difference between the two that I noticed. Let me know what else you need to continue troubleshooting. Thanks.

That makes no sense to me: This sentence sounds like you don’t have access to the web UI of the PI (it doesn’t matter where from you have access), while all other sentences sound like you do have access. So I assume you actually do:
Please post screenshots of the web UIs of both the PI and windows.

Sorry if I’m not communicating things correctly. Maybe I’m using the term “headless” incorrectly. What I mean is no OS on the PI SSH/terminal access only, no monitor connected directly to the PI. All I was saying is I can’t physically use a browser on the PI to log into the GUI since I don’t have an OS installed, but yes I can access the PI’s gui through my desktop browser.

Here are the screenshots from both GUIs.

The MINE PI shows disconnected in the windows gui because after I entered the PI’s ID in the windows GUI I never recieved a link up request in the PI’s GUI.

You are running v1.0.0 on the PI, that’s ancient. It’s not clear if this is the problem but it’s definitely not good. I suggest upgrading using apt.syncthing.net

Wow, I clearly updated it incorrectly after tomasz86 mentioned that.

Ok it has been updated for sure now. I deleted the device from my windows syncthing then added the pi ID back in to send the request again, but still nothing is happening.

I know I’m stuck on the “pause” symbol, but what exactly does that mean? I ask again because I noticed that the windows GUI displayed the pause icon after I deleted the PI from the device list. Then when I added the pi back in the pause sign went away.

Anyway, are there some logs or something that I can post here that will help?

(you actually do have an OS (Operating System) installed, which is Debian Linux; What you meant to say was that you don’t have a UI (User Interface) installed, which creates graphical output for a directly connected monitor; Hence, you only can access the Syncthing web GUI for your Raspberry Pi only indirectly via a connection from another computer by using the configuration) Just to clarify some terminology.

Forget the pause symbol, that doesn’t matter. What matter is if they can discovery each other. You can expand the remote device on the windows side to see that.

Haha, awesome yes thank you. Clearly a noob here, so thank for the patience and clarification.


This is what I see when I expand the remote device on the windows syncthing. In the “edit” menu I have the PI ID and Name, I have it set as an introducer, and all other settings are default. So anything else I can look at to figure out why the PI isn’t receiving the link request from the windows?

My guess is that you have to share a folder with the Pi to establish a connection.

I tried that too, but nothing happens. I’ve also tried adding my windows device ID to the PI, but both the windows device and PI still show as disconnected when I do that.

Make sure that the network connection in Windows is set to “private” and not “public”. The latter will not allow direct connections, even if it is the same LAN.

Also, have you disabled some of these four options that are normally enabled by default?

If yes, then I would suggest enabling them again and see if there is any difference. Of course, you can still use Syncthing without relying on any external discovery mechanisms, but then you may also need to hard-code the IP addresses and such.