Puller ... rename .... Access is denied ?

Hi All,

I’m trying to use Syncthing in my office, but have a problem. On my workstation PC (Windows 10) I have a folder on my Desktop, installed Synchthing, and shared the specific folder. On Ubuntu I have installed Syncthing and connected the workstation PC as Remote to it. The folder did sync correct and transferred all files from the PC to Ubuntu. After that I connected secondary workstation PC to Ubuntu, to share the same folder… and now I have ton of errors on both workstation PCs, claiming:

> Puller (folder “Oferti” (Oferti), item “1\2\3.xls”): syncing: rename \?\C:\Users\me\Desktop\Оферти\1\2\3.xls \?\C:\Users\me\Desktop\Оферти\1\2\3.sync-conflict-20211227-142600-GSCAHAL.xls: Access is denied.

This happens on more than 500 .xls files in the folder…

Tried marking “Ignore Permissions” on the shared folder on all Syncthing instances, but did not help.

Please help me to setup this? All I want is to have a shared folder between few workstation PCs via Syncthing and also installed on Ubuntu to act as a “backup” with retention policy on the folder.

I tried fresh new install of Syncthing instances on all workstations and Ubuntu, transfered the folder and files before sync/remote… they sync OK, but then I tried to add simple .txt document on one of the folders, and on another workstation I got instant error:

Puller (folder “Оферти” (Оферти), item “test.txt”): syncing: rename \?\C:\Users\me\Desktop\Оферти~syncthing~test.txt.tmp \?\C:\Users\me\Desktop\Оферти\test.txt: Access is denied.

So… is this some kind of write permission problem on my Windows workstations? What should I do?


Actually, I see that on the sync process, the “test.txt” document was transfered from one workstation to another, but with “.tmp” added to it. Then the local Syncthing instance tried to rename the “.tmp” back to the original name of the file, but give “access is denied” error. Please help?

Its a permission issue coming from the operating system, not a syncthing.

Check OS permissions, ACLs (if the platform uses them).

Ok, after more testing with Syncthing instances and following sync methods:

Windows<->Ubuntu<->Windows and Windows<->Windows

I can now see that the problem should be on the Windows, as the problem persist on the second test, too.

I don’t use ACLs, my Windows workstations are on a domain. I don’t see any options on Syncthing (I use SyncTrayzor, actually). Where should I add permissions? What is the plan here - add my Windows user account username/password somewhere in Syncthing, or what exactly? I tried reading all the documentation of Syncthing, but nothing on permissions and Windows.

Any suggestions?

No, it’s just standard windows permission management, allowing the user that runs syncthing to access those files.

The internet has plenty of guides how to manage permissions on most operating systems.

Well, I tried giving permissions on the shared folder for anyone - admin, domain user, administrator of PC, administrator of domain… also tried “owner of…” to be any of them, but still the same error on Syncthing.

The internet does not give any info regarding such a problem with this or other software… very strange behavior.

There seems to be no solution, but I wanted to use this software.

Did you check which user Syncthing is running as (how did you start it) and what the permissions are on C:\Users\me\Desktop\Оферти\1\2\3.xls and it’s parent directory? Are/were the files opened, maybe office/windows somehow locks them?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.