Proxy and Syncthing restart


I use Syncthing with a SOCKS5 proxy for one of my node, and that works very well. For that (A Windows) i use this variable before launching Syncthing :

set all_proxy=socks5://localhost:8080

The problem is when Syncthing autoupdate or when i need to do a restart due to a config change, Syncthing lost the proxy after the restart.

I try to launch with a .bat file but that do not solve the problem.

It is possible to integrate proxy settings directly in Syncthing configuration to avoid this problem ?


You can set all_proxy in the environmental variables for your account (it’s hiding somewhere in the Control Panel, or search for “environment” from the Start Menu brings it up). Click “New” under “User variables for PnYMaT”, variable name is all_proxy, variable value is socks5://localhost:8080.

If you’re using SyncTrayzor, you can set it in the Settings: Syncthing tab -> Advanced -> Environmental Variables.

Many thanks, i will set it in environmental variables. But i will try later SyncTrayzor on my computer. :slightly_smiling:

I try on my laptop your software Synctrayzor … i love it :smiley:

A great thanks for your work, I will keep it :slight_smile:


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.